Announcement

Collapse
No announcement yet.

Punkbuster will not update

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Punkbuster will not update

    I have not played Battlefield 2 in 3+ years. I installed the patches up to 1.5. It still wont let me get online to play. I was told to update Punkbuster. I attempted to open it and it takes me to this.



    From here I am lost.

  • #2
    Re: Punkbuster will not update

    You need to extract pbsetup then run it, it will not work trying to run it from inside WinRAR, just right click on the zip file and select "extract file.." then tell it which folder to extract it to.
    Last edited by MrMojay; 02-22-2011, 03:51 PM. Reason: opps my bad

    Comment


    • #3
      Re: Punkbuster will not update

      Never mind mojay. He only sees 2142.
      Latest patch for BF2 is indeed 1.5. You also need to extract pbsetup, because it needs to create some files.
      If you are using Vista/7, try running it as administrator.
      Proud to have been an Irregular!

      2142: Medic4Hire - BF4/Origin: MedicNL

      Comment

      Connect

      Collapse

      TeamSpeak 3 Server

      Collapse

      Advertisement

      Collapse

      Twitter Feed

      Collapse

      Working...
      X