Announcement

Collapse
No announcement yet.

Bad PSU (i think)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad PSU (i think)

    so, i went to boot my computer up sunday morning.... i noticed the lites on my headphones (baracuda) were off.... they are on even if the computer is off... so i hit the power button... nothing. the whole rig is all but a year old (i built it last april) the PSU is an Antec SmartPower 2.0 500 watt.... tried different outlet.. different power cord.... if it isnt the psu.. then its the MB ( =( ) <-- good excuse to upgrade =D.. thoughts? suggestions? tests i can do to be sure?
    powered by Windows 7

    . . . .

  • #2
    Re: Bad PSU (i think)

    Only way to be sure is to find another PSU to test on it. Also check your motherboard to see if there is a a power button on the board itself, possible the front panel button was disconnected.

    Comment


    • #3
      Re: Bad PSU (i think)

      Different thread but the same applies:
      http://www.tacticalgamer.com/hardwar...tml#post669893
      Retired 6th DB

      Comment


      • #4
        Re: Bad PSU (i think)

        I've had Antecs die on me in short order. It's sad but true that they are not as good as people think.

        Jaykay (FastBK) |null|

        Comment


        • #5
          Re: Bad PSU (i think)

          ya so... picked up a new PSU... psu was the problem.. but after getting my system up and running... i found out that EVERY USB PEREPHRIAL I HAD PLUGGED INTO MY COMPUTER.... fried
          g15 keyboard
          printer
          joystick
          razer baracuda 5.1 headphones
          wifi hub (for nintendo wii)
          ipod
          mouse

          /emo suicidal

          $1000. in usb stuff
          $150 new psu

          there went half my tax refund
          powered by Windows 7

          . . . .

          Comment


          • #6
            Re: Bad PSU (i think)

            Was there a storm? You might can claim that stuff on your insurance.
            Retired 6th DB

            Comment


            • #7
              Re: Bad PSU (i think)

              Originally posted by Wimpinator View Post
              Was there a storm? You might can claim that stuff on your insurance.
              What he said. Or if you used a power surge (a nice one) most come with warranties.
              USAR

              Comment


              • #8
                Re: Bad PSU (i think)

                Originally posted by squeak View Post
                What he said. Or if you used a power surge (a nice one) most come with warranties.
                no storm... all was calm all weekend... surge protector is a few month old 5k joule belkin... besides that... only the computer itself was affected... usb ports are fine.. mobo is fine... and for some odd reason.. my g15 decided to work... no luck with anything else... i blame the psu.. i doubt there is a warranty/guarantee on the old one (i dont have the paperwork at this location)
                powered by Windows 7

                . . . .

                Comment

                Connect

                Collapse

                TeamSpeak 3 Server

                Collapse

                Advertisement

                Collapse

                Twitter Feed

                Collapse

                Working...
                X