Announcement

Collapse
No announcement yet.

Seeking help with Razer Diamondback mouse

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Seeking help with Razer Diamondback mouse

    Hey Guys I am having some issues with my mouse. I recently tried to update the drivers to my mouse and during the update install I blue screened and had to reboot. Ever since my side buttons no longer work. I have gone from 5.09 to 6.1 to 6.2 drivers and nothing seems to work. I have tried mapping different keys just to see if the buttons work outside of POE2 and it seems to work just fine but when I map my keys for voip, crouch and parachute the buttons don't work but the on the fly sensitivity does work in game. That is the only button that seems to work other the the left and right buttons. I have uninstalled previous drivers before reinstalling the newer drivers and that didn't work. I have completely removed the mouse via device manager and rebooted then reinstalled the drivers and that hasn't helped either. Anyone have any other avenues I might be able to travel? Thanks in advance for any help
    sigpic

  • #2
    Re: Seeking help with Razer Diamondback mouse

    that's kind of what happened to me, 'cept windows was corrupted, but it has lots of blue screens :D.

    I've tried all that too, any advice would be greatly appreciated.
    <<<<Magic!!




    -F- Concr3te: "Brutus, goddammit, shut up!"

    Comment

    Connect

    Collapse

    TeamSpeak 3 Server

    Collapse

    Advertisement

    Collapse

    Twitter Feed

    Collapse

    Working...
    X