Announcement

Collapse
No announcement yet.

Dual Boot xp & linux = BAD GRUB

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dual Boot xp & linux = BAD GRUB

    Well, I felt like playing around with a linux install and got an install of ubuntu to throw on it's own HD. The install installed GRUB for dual booting XP and ubuntu, except now I keep getting a GRUB error 17, and can't access either OS.

    I'm more then a little "done" with trying to fix this, I've been spending the better part of my sunday tracking down info on the problem but it's all greek to me. Is there any way to fix this from the ubuntu install CD, as I don't have a cd burner or a floppy drive.

    This really sucks btw. Typing on the laptop is such a chore.
    USAR

  • #2
    Re: Dual Boot xp & linux = BAD GRUB

    New to me; I never had a problem adding Ubuntu, though I always put it on the same drive, and installed GRUB there.

    Comment


    • #3
      Re: Dual Boot xp & linux = BAD GRUB

      http://ubuntuforums.org/showthread.php?t=442945

      First google hit for 'GRUB error 17'. Hope it helps!

      - It's who you game with.

      Comment


      • #4
        Re: Dual Boot xp & linux = BAD GRUB

        Thanks sarc, but I've already been googling the hell out of this and can't find a solution.
        USAR

        Comment


        • #5
          Re: Dual Boot xp & linux = BAD GRUB

          If anyone can help...

          Here's my fdisk info:
          Disk /dev/sda: 250.0 GB, 250059350016 bytes
          255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
          Units = sectors of 1 * 512 = 512 bytes
          Disk identifier: 0x0b2d0b2c

          Device Boot Start End Blocks Id System
          /dev/sda1 * 63 488375999 244187968+ 7 HPFS/NTFS

          Disk /dev/sdb: 80.0 GB, 80026361856 bytes
          255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
          Units = sectors of 1 * 512 = 512 bytes
          Disk identifier: 0x084cc165

          Device Boot Start End Blocks Id System
          /dev/sdb1 * 63 150288074 75144006 83 Linux
          /dev/sdb2 150288075 156296384 3004155 5 Extended
          /dev/sdb5 150288138 156296384 3004123+ 82 Linux swap / Solaris

          Disk /dev/sdc: 250.0 GB, 250059350016 bytes
          255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
          Units = sectors of 1 * 512 = 512 bytes
          Disk identifier: 0xda399203

          Device Boot Start End Blocks Id System
          /dev/sdc1 * 63 488392064 244196001 7 HPFS/NTFS

          Disk /dev/sdd: 80.0 GB, 80026361856 bytes
          255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
          Units = sectors of 1 * 512 = 512 bytes
          Disk identifier: 0x084cc166

          Device Boot Start End Blocks Id System
          /dev/sdd1 * 63 156296384 78148161 6 FAT16
          Here's my info from fstab:
          Code:
          # /etc/fstab: static file system information.
          #
          # <file system> <mount point>   <type>  <options>       <dump>  <pass>
          proc            /proc           proc    defaults        0       0
          # /dev/sdb1
          UUID=9f70c7e4-c079-461e-96e0-15bf95db6cb6 /               ext3    relatime,errors=remount-ro 0       1
          # /dev/sdb5
          UUID=66d69b42-11c3-49ba-a7f3-2bc31a33e49a none            swap    sw              0       0
          /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
          /etc/fstab (END)
          and menu:
          title Ubuntu 8.04, kernel 2.6.24-16-generic
          root (hd1,0)
          kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=9f70c7e4-c079-461e-96e0-15bf95db6cb6 ro quiet splash
          initrd /boot/initrd.img-2.6.24-16-generic
          quiet

          title Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
          root (hd1,0)
          kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=9f70c7e4-c079-461e-96e0-15bf95db6cb6 ro single
          initrd /boot/initrd.img-2.6.24-16-generic

          title Ubuntu 8.04, memtest86+
          root (hd1,0)
          kernel /boot/memtest86+.bin
          quiet

          ### END DEBIAN AUTOMAGIC KERNELS LIST

          # This is a divider, added to separate the menu items below from the Debian
          # ones.
          title Other operating systems:
          root


          # This entry automatically added by the Debian installer for a non-linux OS
          # on /dev/sda1
          title Microsoft Windows XP Home Edition
          root (hd0,0)
          savedefault
          chainloader +1
          Device.Map:
          (hd0) /dev/sda
          (hd1) /dev/sdb
          (hd2) /dev/sdc
          (hd3) /dev/sdd
          USAR

          Comment


          • #6
            Re: Dual Boot xp &amp; linux = BAD GRUB

            To get XP back you usually boot with the XP CD, and choose the emergency repair console or suchlike thing. then you issue a fixmbr command (and another one - google for it). That should get XP back.
            Then you can finaggle /boot/grub/menu.lst to try getting grub in order again. Ideally you have a separate HD for Linux. Then you can unplug your XP HD and install clean on the Linux disk and boot the correct OS via the BIOS boot selection (F12 on my Gigabyte I believe).

            Comment


            • #7
              Re: Dual Boot xp &amp; linux = BAD GRUB

              http://users.bigpond.net.au/hermanzone/p15.htm#cli

              Can you get to your GRUB menu? Try the command-line interface to figure out if your device.map is correct in specifying your drives.

              - It's who you game with.

              Comment


              • #8
                Re: Dual Boot xp &amp; linux = BAD GRUB

                I've been able to boot into ubuntu by installing GRUB on that HD and changing the HD boot order via bios. I have to edit the GRUB string and change it from hd1,0 to hd0,0.

                I still can't load XP via the GRUB menu (even though it's a selection).
                USAR

                Comment


                • #9
                  Re: Dual Boot xp &amp; linux = BAD GRUB

                  The HD setting in your GRUB config is probably wrong for XP as well. You'll have to do some more fiddling to figure out what drive it thinks it is.

                  - It's who you game with.

                  Comment


                  • #10
                    Re: Dual Boot xp &amp; linux = BAD GRUB

                    Back in windows. 1. Disabled Linux HD; 2. Boot up with win xp CD; 3. Go to recovery and fixmbr.

                    Le Sigh.
                    USAR

                    Comment

                    Connect

                    Collapse

                    TeamSpeak 3 Server

                    Collapse

                    Advertisement

                    Collapse

                    Twitter Feed

                    Collapse

                    Working...
                    X