Announcement

Collapse
No announcement yet.

need northern strike help?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • need northern strike help?

    I have northern strike but I can not play the game. After loading the game and it finsh loading I get a message that say " This server only allows players with unmodified content to join. revert your version of battlefield 2142 to the current official version to join". I have uninstall the game and reinstall and no luck. Can any one help? Is there a way to fix that proablem with out having to un install the game?

  • #2
    Re: need northern strike help?

    repatch 1.5
    Reapator, overlord of ponies

    Comment


    • #3
      Re: need northern strike help?

      If you need more help, try this section:

      http://www.tacticalgamer.com/battlef...-support-faqs/

      The people that can help might not look in this forum too often.

      Comment

      Connect

      Collapse

      TeamSpeak 3 Server

      Collapse

      Advertisement

      Collapse

      Twitter Feed

      Collapse

      Working...
      X