Announcement

Collapse
No announcement yet.

ATi 9.9 drivers crash on install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATi 9.9 drivers crash on install

    So Im running windows 7 64 RC and Im trying to install the drivers for my 4870. Ever since 9.7 the system crashes when when I try to install the package. I have tried to install single components and still crashes. When I say the system crashes I mean it blue screens and reboots. There is nothing showing up in the event log. If I extract the drivers and install them manually through control panel, they take. But I cant use CCC like that. Has anyone experienced this?

  • #2
    Re: ATi 9.9 drivers crash on install

    Have you checked to make sure Windows Firewall isn't blocking your EXE from executing?

    Have you done a virus scan lately? There's a known nasty little trojan floating out there that messes with executables called "bungo659.exe".
    |TG-18th| Acreo Aeneas
    TG World of Tanks Clan Executive Officer
    Former 9th & 13th

    Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
    Still can't say it? Call me Acorn then. -.-





    SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

    TG Primer and Rules

    Comment


    • #3
      Re: ATi 9.9 drivers crash on install

      Uninstall the driver and then install the new ones. The ATI drivers will not load over the installed drivers like the nVidia drivers.
      Forewarned is Forearmed




      Comment


      • #4
        Re: ATi 9.9 drivers crash on install

        No previous drivers installed, and very unlikely to be a virus- this is after a fresh install of windows.

        Comment


        • #5
          Re: ATi 9.9 drivers crash on install

          Windows installs a driver (generic) for the graphics and you'll still need to uninstall any drivers before installing the new ones. I've had this same issue as well. This took care of it for me. (Sapphire 3850 directx10 agp gpu)
          Forewarned is Forearmed




          Comment


          • #6
            Re: ATi 9.9 drivers crash on install

            I have an ATI card and have never had to uninstall the previous driver in order to install new ones.

            Comment


            • #7
              Re: ATi 9.9 drivers crash on install

              I just installed the 9.9 in the same OS with HD 4850's in Crossfire over the MS video drivers and all works fine. Try this... download Driver Cleaner Pro (free). in stall it, restart your computer, start it in safe mode and run the Driver Cleaner program. Clean all video driver except the MS ones, restart your computer in regular mode and run your Catalyst suite. This has been working for people with this problem.

              Comment


              • #8
                Re: ATi 9.9 drivers crash on install

                Originally posted by MrShawn305 View Post
                No previous drivers installed, and very unlikely to be a virus- this is after a fresh install of windows.
                Heh, that's what I thought when I did a fresh install of Win7 Pro. Three hours later, Anti-Vir says it found a the trojan on my C partition. You never know when the rig is connected to the internet.

                Have you tried installing the drivers (using the EXE) in Safe Mode? It may seem rudimentary but maybe some other program on there is blocking the install process?
                |TG-18th| Acreo Aeneas
                TG World of Tanks Clan Executive Officer
                Former 9th & 13th

                Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
                Still can't say it? Call me Acorn then. -.-





                SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

                TG Primer and Rules

                Comment


                • #9
                  Re: ATi 9.9 drivers crash on install

                  Ok I did a virus sweep, everything is clean. Reinstalled the OS, same problem. Used Driver Cleaner Pro as directed, same problem. If I run the installer in windows it blue screens and reboots with no error message and nothing in the event log. If I run it in safe mode I get an error saying "Failed to load detection driver". It appears to be in the same spot at where it BSOD in regular mode. Im at a loss as to why this is happening. Ill try running DCP again and installing in regular mode and see what happens. I may end up having to call tech support and see what they have to say.

                  Comment


                  • #10
                    Re: ATi 9.9 drivers crash on install

                    There is a newer driver, skip this one and try the next.

                    http://game.amd.com/us-en/drivers_catalyst.aspx
                    Forewarned is Forearmed




                    Comment


                    • #11
                      Re: ATi 9.9 drivers crash on install

                      I get the same problem with the 9.10 driver as well. Thats the one I was working with in my last post.

                      Comment


                      • #12
                        Re: ATi 9.9 drivers crash on install

                        I've an old 3.4 Northwood P4 running Vista and a HD3850 that loaded and ran these drivers without issue so I guess I can't be much help.
                        Forewarned is Forearmed




                        Comment


                        • #13
                          Re: ATi 9.9 drivers crash on install

                          Crap. I can install the driver manually after extracting it through device manager, but I cant install the CCC. I get the same error. Even if I only download the CCC package. Does anyone have a 9.7 or older driver package? I think that worked up until 9.8

                          Comment


                          • #14
                            Re: ATi 9.9 drivers crash on install

                            ok well I got the 9.7 CCC installed while using the 9.10 drivers. I would still like to fix this and get the latest CCC installed.

                            Comment

                            Connect

                            Collapse

                            TeamSpeak 3 Server

                            Collapse

                            Advertisement

                            Collapse

                            Twitter Feed

                            Collapse

                            Working...
                            X