Announcement

Collapse
No announcement yet.

Screen Flickers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Screen Flickers

    Help! So yesterday, I installed my new 5870. That evening and this morning, it ran perfectly. Today, I booted up and I get flickering on my second monitor. I reinstalled my drivers; no luck. It gets extremely bad when I open up any game. I checked the refresh rate on both of my monitors; set at the correct rate. Could this be my new card acting up? Temps seem okay.

    Help! I can't game and my eyes hurt.

    UPDATE: It only occurs when my second monitor is in use. What's up with that?


  • #2
    Re: Screen Flickers

    Have you tried switching the monitors to see if one of the DVI plugs in the back might be faulty?
    |TG-6th|SirNerd

    My Resume includes Pirate, Mercenary, and a Devil Dog, what else do you want.

    Pain is Inevitable, Suffering is Optional.

    When you can't run anymore, you crawl and when you can't do that, you find someone to carry you.

    Comment


    • #3
      Re: Screen Flickers

      Are you using the latest 10.4 drivers Beat? Have you tried using 10.4a or 10.3 drivers? I've heard similar reports of screen flickering in several games with ATI drivers.
      |TG-18th| Acreo Aeneas
      TG World of Tanks Clan Executive Officer
      Former 9th & 13th

      Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
      Still can't say it? Call me Acorn then. -.-





      SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

      TG Primer and Rules

      Comment


      • #4
        Re: Screen Flickers

        I'm using the 10.4 drivers, I'm uninstalling them and rolling back to 10.3 right now.

        UPDATE: Rolled back to 10.3, I still have the flicker.

        FIXED: Disabled ATI Overdrive. I'm going back to 10.4 with it disabled.
        Last edited by DrBeat; 05-18-2010, 09:09 AM.

        Comment


        • #5
          Re: Screen Flickers

          Originally posted by DrBeat View Post
          I'm using the 10.4 drivers, I'm uninstalling them and rolling back to 10.3 right now.

          UPDATE: Rolled back to 10.3, I still have the flicker.

          FIXED: Disabled ATI Overdrive. I'm going back to 10.4 with it disabled.
          Ah you had overdrive on. Don't OC the memory from now on. For some reason when the memory is OC'd, there are screen flickers (not card specific). I had thought you had everything on stock settings. Should have asked about any OC first.
          |TG-18th| Acreo Aeneas
          TG World of Tanks Clan Executive Officer
          Former 9th & 13th

          Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
          Still can't say it? Call me Acorn then. -.-





          SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

          TG Primer and Rules

          Comment


          • #6
            Re: Screen Flickers

            Originally posted by Acreo Aeneas View Post
            Ah you had overdrive on. Don't OC the memory from now on. For some reason when the memory is OC'd, there are screen flickers (not card specific). I had thought you had everything on stock settings. Should have asked about any OC first.
            I didn't mess with them memory, I just had the fan at a higher rate. Go figure.

            Comment

            Connect

            Collapse

            TeamSpeak 3 Server

            Collapse

            Advertisement

            Collapse

            Twitter Feed

            Collapse

            Working...
            X