Announcement

Collapse
No announcement yet.

[Help!]Pixels acting funky

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Help!]Pixels acting funky

    I appear to have developed a lot of pixels that aren't displaying properly

    Behaviour
    They behaving weirdly, I can't screen shot them. I can cover them with my mouse/cursor. They move about and if i scroll sometimes disappear but will come back if something moves on the screen. they are various colours though the majority are shades of grey. some times theres a lot of them, other times not many.

    heres an attempt at taking a photo of them




    all help appreciated.
    AnimalMother
    Ex TG-31st LR
    "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
    sigpic

    Arte et Marte

  • #2
    Re: [Help!]Pixels acting funky

    Ruh-roh. I used to have a similar issue aeons ago. It was an overheating video card. The fan on it wasn't working properly. I bought something like this as temporary fix. It actually fixed my problem for a while, until the card just finally had it. Bought me another year, though.
    http://www.newegg.com/Product/Produc...-024-_-Product
    "Common sense is not so common." -Voltaire

    Comment


    • #3
      Re: [Help!]Pixels acting funky

      i hope it aint, how can i check the temp of the card?


      using catalyst control centre it was at 40 degC on desktop and then 60degC when playing, and in game the pixels behave themselves and there seems to be no performance drop
      AnimalMother
      Ex TG-31st LR
      "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
      sigpic

      Arte et Marte

      Comment


      • #4
        Re: [Help!]Pixels acting funky

        Well, those are very healthy temperatures. So maybe that's not the problem. Could have something to do with the 2-d performance of the card. Did this happen right after updating drivers perhaps? Or perhaps you're in need of a driver update.
        "Common sense is not so common." -Voltaire

        Comment


        • #5
          Re: [Help!]Pixels acting funky

          Originally posted by War.mongeR1 View Post
          Well, those are very healthy temperatures. So maybe that's not the problem. Could have something to do with the 2-d performance of the card. Did this happen right after updating drivers perhaps? Or perhaps you're in need of a driver update.
          it happened randomly this afternoon, without me changing anything.
          AnimalMother
          Ex TG-31st LR
          "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
          sigpic

          Arte et Marte

          Comment


          • #6
            Re: [Help!]Pixels acting funky

            You're not overclocking your graphics card in anyway are you? If you are, revert the clocks back to stock.

            Have you tried a different monitor or cable? I've had that issue before only to realize after 3 days that the monitor cable was the culprit.
            |TG-18th| Acreo Aeneas
            TG World of Tanks Clan Executive Officer
            Former 9th & 13th

            Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
            Still can't say it? Call me Acorn then. -.-





            SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

            TG Primer and Rules

            Comment


            • #7
              Re: [Help!]Pixels acting funky

              Originally posted by Acreo Aeneas View Post
              You're not overclocking your graphics card in anyway are you? If you are, revert the clocks back to stock.

              Have you tried a different monitor or cable? I've had that issue before only to realize after 3 days that the monitor cable was the culprit.
              nothing in my system is overclocked

              going to try switching stuff out tomorrow
              AnimalMother
              Ex TG-31st LR
              "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
              sigpic

              Arte et Marte

              Comment


              • #8
                Re: [Help!]Pixels acting funky

                Well i am a bloody happy chappy!


                turn my PC on this morning and everything is as it should be! hopefully it was just a one off


                thank you to everyone that helped diagnose what it was, really appreciated
                AnimalMother
                Ex TG-31st LR
                "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
                sigpic

                Arte et Marte

                Comment


                • #9
                  Re: [Help!]Pixels acting funky

                  I was a happy chappy, they have come back with vengeance now

                  I've tried it with two different monitors and switched between DVI and VGA with no effect, the only advance i made was disabling my primary display adapter (Radeon 5770 series).

                  I'm guessing this means i've overheated my GPU at some point and done damage because like i said before it isn't having overheating issues atm and games run fine, its just the dam dots everywhere

                  Someone with good knowledge confirm i have damaged it or are there any other things i can try?
                  AnimalMother
                  Ex TG-31st LR
                  "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
                  sigpic

                  Arte et Marte

                  Comment


                  • #10
                    Re: [Help!]Pixels acting funky

                    Are you using the latest 10.5 Catalyst driver?

                    Do you have any wireless devices or high-powered electronics near your monitor? (For example: a hair dryer you use near the monitor, a unshielded speaker woofer, etc.)

                    If you rule out drivers and interference, I'd call up your graphics card manufacturer and request a RMA for a replacement card.
                    |TG-18th| Acreo Aeneas
                    TG World of Tanks Clan Executive Officer
                    Former 9th & 13th

                    Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
                    Still can't say it? Call me Acorn then. -.-





                    SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

                    TG Primer and Rules

                    Comment


                    • #11
                      Re: [Help!]Pixels acting funky

                      yeh just installed 10.5 today


                      i do have a sound system next to my monitor but had them by it since i got the PC, it was fine for months. and i've just unplugged it all and restarted with no fix

                      unless somethings happened next door (though would it make that much of an effect through a wall?) which i wont be able to see

                      thanks for the help


                      edit:: just went to there website, filled in a form about the problem and asked about RMA. hopefully there'll be a solution or a replacement :D
                      Last edited by AnimalMother; 05-31-2010, 08:35 PM.
                      AnimalMother
                      Ex TG-31st LR
                      "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
                      sigpic

                      Arte et Marte

                      Comment


                      • #12
                        Re: [Help!]Pixels acting funky

                        Originally posted by AnimalMother View Post
                        unless somethings happened next door (though would it make that much of an effect through a wall?) which i wont be able to see
                        If your neighbors had such a device that could emit such high EMs across that distance and through your house exterior walls, it would affect a lot more than just your monitor. Other electronics in your house would probably be acting funky/crazy.


                        Well, hopefully your RMA will go through and you get a replacement card AND that fixes your pixel problems.
                        |TG-18th| Acreo Aeneas
                        TG World of Tanks Clan Executive Officer
                        Former 9th & 13th

                        Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
                        Still can't say it? Call me Acorn then. -.-





                        SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

                        TG Primer and Rules

                        Comment


                        • #13
                          Re: [Help!]Pixels acting funky

                          given our house's performance of late i wouldn't be surprised lol
                          AnimalMother
                          Ex TG-31st LR
                          "Is it the 31st policy to have hott women as their avatars? Because if so that's a pretty baddass policy." - Pvt. brokeback
                          sigpic

                          Arte et Marte

                          Comment


                          • #14
                            Re: [Help!]Pixels acting funky

                            Meanwhile, you could probably pick up a decent "last-generation" card for under $100. That's what I did a year or two ago when my 8600 died. I ran over to Fry's and got an nVidia 9500GS and that was enough to allow me to play WoW and BF2 on my 25.5 inch flat panel. At the time the card cost me about $90, and I think it's closer to $50 right now.
                            Dude, seriously, WHAT handkerchief?

                            snooggums' density principal: "The more dense a population, the more dense a population."

                            Iliana: "You're a great friend but if we're ever chased by zombies I'm tripping you."

                            Comment


                            • #15
                              Re: [Help!]Pixels acting funky

                              Speaking of last-gen cards, The 1 GB HD4850s go for about $90-$100 a pop nowadays. Would be a great backup card without sacrificing on gaming performance or installing nVidia drivers.
                              |TG-18th| Acreo Aeneas
                              TG World of Tanks Clan Executive Officer
                              Former 9th & 13th

                              Pronounciation: Eh-Cree-Oh Ah-Nay-Ess
                              Still can't say it? Call me Acorn then. -.-





                              SSDs I Own: Kingston HyperX 3K (240 GB), Samsung 840 Pro (256 GB), Samsung 840 EVO (250 GB), Samsung 840 x 2 (120 GB), Plextor M5S (120 GB), OCZ Vertex (30 GB)

                              TG Primer and Rules

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X