Announcement

Collapse
No announcement yet.

Configuring sound on wegame

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Configuring sound on wegame

    Hey guys,

    I'm interested in using wegame to record some gameplay videos in BF2 (PR actually). Thing is, I'd really like to record both the in-game sound and my microphone. I've been able to record my mic by piping it through my headset, but this setup distorts my voice and forces me to listen to the playback. Is there some way I can record both in-game sounds and my mic without this obnoxious fix? My sound card is pretty cheap, a Sound Blaster Audigy 2 Value, so I'm concerned that it may prevent me from recording properly. Also wegame seems to force me to record through the "What U Hear" channel. I'm open to using other recording programs but I would prefer to use wegame as it has good compression and is easy to use.

    Thanks

    *Edit*

    I just saw Silver's "Recording all sounds" thread. I should have read through that before I made this post.

    The thing is, I did make a wegame video once where both my mic and sounds were recorded. I remember not having to pipe my microphone through my headset. I could be misremembering but, when I go back and watch the video, my voice is not distorted in it, which is what happens when pipe my mic through my headset.

    *Edit #2*

    I just ran a quick test and found that if I set my speaker settings to "Desktop Stereo Speakers" instead of "Stereo Headphones" it gets rid of all the annoying distortion.
    Last edited by Charity Case; 02-18-2009, 02:26 AM.

  • #2
    Re: Configuring sound on wegame

    Quick question about wegame:

    I have no problems recording all the sounds in the game after following instructions on the other thread. However, it seems like my in-game voip stops working every time I start recording.

    While in the server, I'd alt-tab out and make sure that "Mic Volume" is selected. While recording, I'll do a tap test, and the mic is definitely still live, but nobody can hear me in-game anymore, even though my voice still gets recorded by wegame. After I stop recording, I'd alt-tab out, and "Stereo Mix" is somehow magically selected (see image below).



    How do I keep "Mic Volume" selected throughout the recording?

    I'm on a Macbook Pro, but I boot into Win XP for gaming. The image you see above are all the options that I have for recording. I can't figure out what step I'm missing. I don't have this problem with Fraps, but I'd prefer to get wegame working because my laptop can't handle the huge file sizes generated by Fraps.

    Will appreciate any help/suggestions that I can get. Cheers.

    Edit: It turns out I have the same problem with Fraps too. Was playing fine, hit "record" and suddenly everyone on the squad was saying "I can't hear your mic anymore." Tap-test was fine during recording though. And once I stopped recording, people could hear me again.
    Last edited by pinkypig; 03-13-2009, 02:21 AM.

    Comment


    • #3
      Re: Configuring sound on wegame

      I can confirm 'mic' should be selected and not 'stereo mix'
      I do know 2142 on my xp set up, does mute mic sometimes, like when exiting a map to 2142 menus
      Maybe 2142 is messing with your settings at key moments like map load

      I suggest you alt-tab out when the map is loaded (risking an alt tab crash) and then unmute and tic mic, then alt tab back into game.

      So try experimenting with when you alt tab

      my setting below

      Comment


      • #4
        Re: Configuring sound on wegame

        Originally posted by Exploding_Silver View Post
        I suggest you alt-tab out when the map is loaded (risking an alt tab crash) and then unmute and tic mic, then alt tab back into game.
        Thanks. I tried alt-tabbing to tic mic and it still doesn't work. The steps that I did:

        1. Load map, alt-tab out in the middle of a game
        2. Ticked mic, alt-tab back into the game
        3. Start recording: Tap-test works, I can hear myself, but no one can hear me in-game
        4. Stop recording, alt-tab out and "Stereo Mix" is now ticked. :row__684: I absolutely did not touch it.

        I just can't, for the life of me, figure out why "Stereo Mix" becomes selected. I'm already ticking "Microphone" right before I start recording, what step am I missing?

        That was for Wegame. It's gets even weirder for Fraps. "Microphone" remains selected, yet no one hears me in-game when I'm recording. The moment I stop recording, people can hear me again.
        I thought the recording was pretty straightforward and now I'm wondering if the problem is specific to the mac hardware.

        Comment


        • #5
          Re: Configuring sound on wegame

          I can't help you anymore, sorry
          It does seem to be harware
          You understand what combo needs ticking/unticking, its just the game seems to inside on ticking stereo
          One last thing to try is another game to see if its 2142 only or applies to all games

          Comment


          • #6
            Re: Configuring sound on wegame

            It's alright Silver, thanks for your help, I appreciate it.
            I will go try it on L4D. It's too bad I can't get it to work on BF2142. It's the only game that I want to record, and I don't really play other games. Thanks again.

            Comment


            • #7
              Re: Configuring sound on wegame

              Just to update, I get the same problem with L4D using Fraps. Everything records fine, but nobody can hear me in-game. So I think the problem is definitely with my computer.

              Comment


              • #8
                Re: Configuring sound on wegame

                for info
                if i record and my mic is muted then noone can hear me ingame

                Comment


                • #9
                  Re: Configuring sound on wegame

                  Originally posted by Exploding_Silver View Post
                  for info
                  if i record and my mic is muted then noone can hear me ingame
                  Yup, my mic was un-muted, I followed the exact settings you posted in your photo earlier. :) I have now given up and will just record the game when I can afford not to have in-game mic. :madsmile:

                  Comment

                  Connect

                  Collapse

                  TeamSpeak 3 Server

                  Collapse

                  Advertisement

                  Collapse

                  Twitter Feed

                  Collapse

                  Working...
                  X