Announcement

Collapse
No announcement yet.

FRAPS Audio out of sync in long files (VirtualDUB)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FRAPS Audio out of sync in long files (VirtualDUB)

    Hello guys!

    FRAPS puts 4GB chunks on my HDD. With VirtualDUB I can put them together in ONE BIG video.

    Even without encoding - the further I go in the video, the more the audio is not sycned with the video. The sound comes too early.
    Every single 4GB file is good, but when putting them together... :-/

    I tried to solve the problem with delaying the audio with VirtualDUB and the outcome was great. My final AVI files were ok. But after uploading to youtube...

    http://www.youtube.com/watch?v=1JbNycSMcD8#t=2m23s

    Dammit. What to do? I recorded a whole game yesterda (1hr) and I want to make sure the audio is sycned!
    There must be a problem putting the files together for VirtualDUB.

    Anyone any ideas?

    Thank you very much in advance!

  • #2
    Re: FRAPS Audio out of sync in long files (VirtualDUB)

    I've never used VirtualDUB, but did you try uploading the first set of avi's that you put together to YouTube to see if they played correctly, even though they weren't appearing to be sync'd on your computer?

    I did a little searching and found this
    Thanks for your inquiry. The 4 gigabyte limit is imposed to maintain compatibility with all video editing programs. Some applications have problems once video files are larger than this. However, we have found that most video editing programs will allow you to import multiple files into a single project for encoding.

    Alternatively, you could use a program called VirtualDub (www.virtualdub.org) to combine the files together.

    To do this, simply open the first video file in the sequence in VirtualDub and then add the other video files by using the "Append AVI Segment" option under the File menu. You will also need to make sure that the video mode is set to "Direct stream copy" (under the Video menu), and the audio mode set to "Source Audio" and "Direct stream copy" (under the Audio menu).

    Once you have added the files and configured the video and audio settings, you can select the "Save as AVI" option under the File menu to write the combined file to your hard drive. After VirtualDub has finished you will be able to watch the combined file in your media player software.

    Official response to my inquiry I re inquired the same day I posted... I am sending back a request for it to be an option as that I think if I can cut out the extra steps I can get on with what I want to do with the video...

    Cheers ~Ajax
    on this forum post. http://forums.steampowered.com/forum...d.php?t=958598

    Is that how you put the two avi's together? and did you have the video and audio modes set as the post suggests?

    Good luck!
    Big-eye101: "A true catman post a day keeps the bad mood away"

    Please do not take any posts made by Catman seriously. If you begin to take his posts seriously, please seek psychiatric attention.

    Comment


    • #3
      Re: FRAPS Audio out of sync in long files (VirtualDUB)

      Hey, thank you a lot for your response! Unfortunately I tried everything named above. The problem is inside VirtualDUB, the way it connects the files is corrupt. Every single file is ok, but together they are a mess. :-/

      Comment


      • #4
        Re: FRAPS Audio out of sync in long files (VirtualDUB)

        go back to the raw fraps files, how many are there? what size are they? do they play in media player with sound and visuals in synch ?
        are things ok at that raw video stage or does it happen after that where the unsynch happens ?

        fraps normally is reliable for having sound and visuals in synch. at least in my experience

        Comment


        • #5
          Re: FRAPS Audio out of sync in long files (VirtualDUB)

          Hey Silver thank you for responding!

          In my footage there are 21 files. A lot of them are 4gb chunks, the others are smaller because of partial non-recording (I stopped for alt-tabbing etc).

          Every SINGLE RAW file is good. No sync problems at , everything perfect.
          AS soon as I "append video segment" in VirtualDUB the audio starts getting out of sync. The first chunk is good, then in the 2nd chunk it's a bit early and with every chunk it gets worse (audio is too early) up to half a second or so in the end of the whole footage.

          What I dont get is that even after correcting the audio with delay the video becomes bugged again after uploading to YouTube, it's like I never changed it.
          I had the problem earlier on my old system and there I solved it by delaying the audio. Does not seem to work today on YouTube though the files are good after correcting... :-/

          Comment


          • #6
            Re: FRAPS Audio out of sync in long files (VirtualDUB)

            Bump.

            Comment


            • #7
              Re: FRAPS Audio out of sync in long files (VirtualDUB)

              so raw fraps files are good
              importing in virtualdub is not good, I say cut your losses with that app
              use another program, I use sony vegas platinium (costs) or try windows movie maker (on your machine now)

              have you tried windows movie maker ?

              or search web for a free trial editor

              thats my best suggestions

              Comment


              • #8
                Re: FRAPS Audio out of sync in long files (VirtualDUB)

                I tried Vegas once and I had a hard time understanding all the settings (pixel ratio, 16:9 or 4:3 etc, i think it should see it automatically), sometimes the compressor wont even start just because ... I dunno. Some resolution problems, its weird. :-/

                Comment


                • #9
                  Re: FRAPS Audio out of sync in long files (VirtualDUB)

                  I agree with Silver on this one. vdub is easy to use and all, but it has not been maintained since 2006, so you are bound to run into trouble using it with todays operating systems, drivers and video codecs.
                  former TacticalGamer European Division



                  A Tactical Gamer since 2005 (the glorious days of BF2)

                  Comment


                  • #10
                    Re: FRAPS Audio out of sync in long files (VirtualDUB)

                    W000t? ITS SO OLD?!

                    Wow... Ok.


                    Is there a way to bench-process in Vegas? And like shut down computer after rendering?

                    I love Dub for such stuff. :)

                    Comment


                    • #11
                      Re: FRAPS Audio out of sync in long files (VirtualDUB)

                      Woops, disregard. I just re-checked and it seems there is a maintained version out there on http://virtualdub.sourceforge.net/

                      Have to try this version 1.9.9 some time :)
                      former TacticalGamer European Division



                      A Tactical Gamer since 2005 (the glorious days of BF2)

                      Comment


                      • #12
                        Re: FRAPS Audio out of sync in long files (VirtualDUB)

                        Nope, still getting the out-of-sync...

                        Well, I will have to take a workaround... Like just save the video data with Vegas without compressing (jesus...) and proceeding with Vdub...

                        Or, if Vegas has following features I will stay on Vegas.

                        Is there a way to bench-process in Vegas? And like shut down computer after rendering?

                        Comment


                        • #13
                          Re: FRAPS Audio out of sync in long files (VirtualDUB)

                          Hey guys, working with Vegas goes well so far.
                          Just one question.

                          I use 1 pass CRF 20 encoding with x264, the image seems sliced in many ... horizontal slices when there is movement on the screen. I think it is called interlacing?
                          That did not happen on VDub so I wonder how I can get rid of this, I am asking because I am not familiar with the ton of settings in Vegas. I just want basic cut&render.



                          Thank you very much in advance guys! :)

                          Comment


                          • #14
                            Re: FRAPS Audio out of sync in long files (VirtualDUB)

                            What file type are you trying to render/save as?

                            I have the youtube recommending settings saved as:

                            .wmv format

                            Then if you click on the Custom button below are the settings I have:

                            Project Tab:
                            Video Quality - Best
                            Audio Tab:
                            (I usually don't change anything here)
                            Video Tab:
                            Mode-CBR
                            Format-Windows Media Video 9
                            Image size- HD (1280x720)
                            Video smoothness-move slider bar to 100
                            Bit Rate Tab:
                            Internet/LAN check box - 4M
                            Big-eye101: "A true catman post a day keeps the bad mood away"

                            Please do not take any posts made by Catman seriously. If you begin to take his posts seriously, please seek psychiatric attention.

                            Comment

                            Connect

                            Collapse

                            TeamSpeak 3 Server

                            Collapse

                            Advertisement

                            Collapse

                            Twitter Feed

                            Collapse

                            Working...
                            X