Announcement

Collapse
No announcement yet.

HOTMACHINA's 5.1 Surround Sound Adventure

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HOTMACHINA's 5.1 Surround Sound Adventure

    Recently treated myself to an ASUS DX2 after my Creative XFI under Windows 7 made me want to pull my own teeth out.

    Having spent a few hours on this I thought i would share my experience.

    Surround sound conceptual level:

    Arma 2 uses a bespoke audio engine the developers feel is required to ensure a realistic battle soundscape.

    Arma 2 makes limited use of Directx9 libraries.
    Arma 2 does not make use of EAX.
    Arma 2 does not directly support 7.1 but users can make use of the "emulated" 5.1 to 7.1.

    Surround sound hardware and software enviroment:

    Dureing testing the following equipment was used.

    Logitech Z-5500 Digital.
    Asus Xonar DX2 PCIE
    Windows 7 RTM

    These instructions can be seen as valid for Vista and Windows 7, I cannot offer advice on Windows XP but I suspect the solution would be roughly the same.

    Surround sound practical steps.

    Arma 2 expects to see a "pure" 5.1 path from amp to HAL and then abstraction via DirectX, to acheive this I recommend users undertake the following:

    STEP 1:

    Check the physical cabling layer.
    Ensure your AMP or other output device is set to 5.1 or Direct 6 Channel (your AMP may vary in essence look for 5.1 setup)
    Ensure all speakers are giving a clear signal with no popping or hissing.

    STEP 2:
    Perform a speaker test, right click volume > Playback devices > Playback > Right click current default > Test. Do you hear all 5.1 speakers clearly?

    STEP 3:

    Remove all drivers and uninstall sound card, not disable, completely uninstall.
    Reinstall device and drivers to latest version of hardware provider.
    REBOOT

    If you are using Creative disable EAX, Crystilizer, and disable "enhanced" auto expand surround.

    If you are using Xonar then ensure 5.1 is selected EQ mode is DEFAULT, Smart Volume is OFF, Dolby Surround is OFF. PCM is ON.

    STEP 4:

    Perform a speaker test, right click volume > Playback devices > Playback > Right click current default > Test. Do you hear all 5.1 speakers clearly?

    STEP 5:

    Typically you will need two devices for an Arma 2 session, a default output and a default recording.

    ThE FOLLOWING STEP IS A RECOMMENDATION FOR A "PURE" SOLUTION BE AWARE THIS MAY SCREW WITH OTHER APPLICATIONS.

    Click START > CONTROL PANEL > SOUND

    Disable ALL devices (right click disable) that are not required in both Playback and Recording, i.e by the end of the process you need to be sure you have only 1 playback device enabled and 1 recording device for your microphone.

    STEP 6:

    Reinstall DirectX 9

    GAH CANT LINK TO URLS AS I HAVNT MADE 15 POSTS. GOOGLE IT :)

    REBOOT

    STEP 7:

    Perform a speaker test, right click volume > Playback devices > Playback > Right click current default > Test. Do you hear all 5.1 speakers clearly?

    STEP 8:

    Launch Arma 2.
    Select > Options > Audio > Default DO NOT SKIP THIS STEP ITS CRITICAL.
    Exit Arma 2.
    Launch Arma 2.
    Ensure you hear the transition sound as you select menu options.

    STEP 9:

    Enjoy Arma 2 in surround sound.


    Please post if you have any further questions.

  • #2
    Re: HOTMACHINA's 5.1 Surround Sound Adventure

    Misc issues as I find them:

    "CRACKING" ON FOOTSTEPS OR GUNFIRE:

    Ensure the PCM sample rate on either the XFI or Xonar is no higher than 96khz otherwise you will hear distortion on treble rich sounds.

    "FLIPPING" OF BASS AND CENTRE SPEAKER:

    Ensure speakers are not set to 7.1 native audio.
    Ensure software for sound card is not supporting 7.1 emulation UNLESS you are using DTS NEO:PC

    AUDIO SOUNDS OFF CENTRE / AUDIO LEANS TO THE LEFT

    Is a known issue in the latest beta, await update from developers.

    INSANELY LOUD TANK RUMBLE / VEHICLE MOVEMENT

    If using either Bass Crossover or FlexBass ensure htat the LFE crossover frequency is 120Hz or lower.

    TEAMSPEAK CRAPS OUT / TEAMSPEAK REPEATS ITSELF

    Launch Arma 2 > Alt + Tab to desktop > Click TeamSpeak so it has focus > Alt + Tab back to Arma 2. This problem is specific to Xonar series.

    Ensure you have only 1 audio output enabled.

    Comment


    • #3
      Re: HOTMACHINA's 5.1 Surround Sound Adventure

      I didn't have any problems setting up or using 5.1 lol And my 5.1 works just fine.

      Comment


      • #4
        Re: HOTMACHINA's 5.1 Surround Sound Adventure

        Yup, the vast majority of users will have no issue with surround sound at all, however like the CTD bug for nvidia users this is one area that is really troubling some people.

        Hope its usefull!

        Comment

        Connect

        Collapse

        TeamSpeak 3 Server

        Collapse

        Advertisement

        Collapse

        Twitter Feed

        Collapse

        Working...
        X