Announcement

Collapse
No announcement yet.

mission editor help?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mission editor help?

    Hi All,

    I've got a clan server going and I want to add some different vehicles to an already existing mission.

    Here's what I can do:

    1.) create a new mission in the editor and insert the addon vehicles.
    2.) unpack the mission I want to edit

    (edit)NM - I figured out why I couldn't load the existing unpacked mission.. found out where to put the folder.

    building on that, how do I set the vehicles to empty? Is there a source for explaining the initializations of various vehicles?

    Cheers!
    (Happy St. Pat's Day!)
    Last edited by Rothgar; 03-17-2009, 11:58 AM.

  • #2
    Re: mission editor help?

    Originally posted by Rothgar View Post
    building on that, how do I set the vehicles to empty? Is there a source for explaining the initializations of various vehicles?

    Cheers!
    (Happy St. Pat's Day!)
    When you place a unit, the "side" value where you choose opfor/blufor should have "empty" as well. If it doesn't appear there, create a unit (a basic infantry soldier will do) as "player" and you should see "empty" now appear in the side list.
    Jex.

    Comment


    • #3
      Re: mission editor help?

      Thanks Jex,

      I've managed to add the vehicles I wanted and now I'm trying to save the mission.

      I've tried everything and can't find a .pbo anywhere.

      Any suggestions?

      Thanks,

      Comment


      • #4
        Re: mission editor help?

        That's because mission's are not saved as a PBO.

        If you want to find your mission you must open your mission folder which is located by default in documents>Arma>missions. Unless you made the mission in under a different user profile, then the mission is saved in documents>Arma>Arma Other Profiles>username>missions
        sigpic
        Pride/Shame of the PLA

        Comment


        • #5
          Re: mission editor help?

          Originally posted by Rothgar View Post
          Thanks Jex,

          I've managed to add the vehicles I wanted and now I'm trying to save the mission.

          I've tried everything and can't find a .pbo anywhere.

          Any suggestions?

          Thanks,
          As commie said, it saves it as a .sqm file. It won't PBO it until you save it as a multiplayer mission (I don't make SP missions so can't speak for that) and that will be saved to your C:\prog files\arma\mpmissions.

          If you haven't already, check out Mr Murray's mission editor manual which has some great stuff in it...

          http://www.armaholic.com/page.php?id=4847
          Jex.

          Comment


          • #6
            Re: mission editor help?

            Also if you have chosen the "Export to multiplayer missions"-option ie. you have it as a .pbo in your MPMissions-folder, you'll have to manually delete the .pbo and after that re-export if you ever want to update it. For some reason Arma doesn't want to overwrite it.

            Comment


            • #7
              Re: mission editor help?

              I must be losing my mind.

              I've tried exporting that mission in every way possible and haven't been able to create the .pbo.

              I've gotten the BItools and tried that too.. BinPBO is just not working for me.. When I can actually get the paths to all the different directories somewhat close to working, it only creates a 12k .pbo and the log shows a bunch of \core\data\font\lucida errors.

              Argh!

              Comment


              • #8
                Re: mission editor help?

                "Export to Mutiplayer missions" or "Export to Single player missions" from the editor, and the .pbo shows up in your Arma/whateverthenameofthemissionfolderwas/

                Comment


                • #9
                  Re: mission editor help?

                  Originally posted by Rothgar View Post
                  I must be losing my mind.

                  I've tried exporting that mission in every way possible and haven't been able to create the .pbo.

                  I've gotten the BItools and tried that too.. BinPBO is just not working for me.. When I can actually get the paths to all the different directories somewhat close to working, it only creates a 12k .pbo and the log shows a bunch of \core\data\font\lucida errors.

                  Argh!
                  You don't need any tools - once you have the mission changes done, save as a "user made mission". When you are ready to test is, click save and "Export as multiplayer mission" or whatever it's called. You should then have the missions in your MPmissions folder where you installed arma. If that isn't working for you, something is wrong.

                  You also might want to add a version number each time you make some changes. If you do this, you'll need to copy the contents (other than the mission.sqm file)of the folder into the new folder.

                  When you save a mission as user made mission, it saves it to C:\My Documents\arma other profiles\yourusername\missions\your%mission%name - once you save it as yourmissionname-v1-2, it will create a new folder with that name but it will only contain the mission.sqm. It won't have the init.sqs, description.ext, scripts, images, etc. They will need to be copied from the original save folder to the new folder.

                  If this doesn't help, it's probably best to go over this on teamspeak which I'd be more than happy to help :)
                  Jex.

                  Comment


                  • #10
                    Re: mission editor help?

                    Thanks Jex!

                    I'll give that a try when I get home!

                    Cheers!

                    Comment


                    • #11
                      Re: mission editor help?

                      Originally posted by Fincuan View Post
                      Also if you have chosen the "Export to multiplayer missions"-option ie. you have it as a .pbo in your MPMissions-folder, you'll have to manually delete the .pbo and after that re-export if you ever want to update it. For some reason Arma doesn't want to overwrite it.
                      I've got exactly the opposite thing happening. It is a GREAT thing, unlike OFP editing, you don't have to rename the mission for each export!

                      Not sure why yours would act differently ...

                      Comment


                      • #12
                        Re: mission editor help?

                        I managed to get the cPBO tool to create the .pbo file.

                        Of course, the file won't work. There is some error that hangs up the mission.

                        Here's what I'm trying to accomplish -

                        I have the EVO_BLUE_MHQ_Parajump.Sara mission running on my clan server.

                        We want to remove the Strykers and insert M2 Bradleys, replace some of the humvees with uparmored versions, and just for fun, throw in the Kiowa for the stinger/hellfire variant. (gotta keep the pilot types happy too)

                        Is there some scripting/editing other than inserting the vehicles into the mission that needs to be done in some obscure .sqf file in order for this to work?

                        I'd also like to fix the winch script, but one step at a time.

                        Thanks,

                        Comment


                        • #13
                          Re: mission editor help?

                          Just use the editor's own export function instead of cPBO. It makes good, functional .pbos every time.

                          Comment


                          • #14
                            Re: mission editor help?

                            That doesn't happen on my computer.

                            I have never gotten Arma Editor to create a .pbo file from any of my attempts to export.

                            I tried to do an edit last night and all I got was a folder with the new name and a mission.sqm file.

                            perhaps it's a permissions thing.. Vista64 is a bit of a pain.

                            Either that, or I'm not waiting long enough for the export to finish. How long does it usually take?

                            Comment


                            • #15
                              Re: mission editor help?

                              Shouldn't take longer than a few secs, and it does work. Yours looks like a problem with read/write permissions, so check that the account you use to run Arma is has both read and write permissions for the entire Arma-folder, and all its files and subfolders. Vista is a bit different compared to XP in this respect, especially if you have installed Arma to Program Files.

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X