No announcement yet.

Loadout editor woes

  • Filter
  • Time
  • Show
Clear All
new posts

  • Loadout editor woes

    Guys, I'm having some major issues with my loadout script on one (or all) of my missions that use the LEA. Generally, it works great, and everyone's kits are applied correctly - the FIRST time you play the mission.

    However, subsequent tries on the mission cause one or more of the players to not get their loadout. Very strange. I've been told before that this is normal, but even last night when we shutdown the mission, switched to a different island/mission entirely, and back, it still didn't work.

    I'm thinking the init.sqf file needs to wait before running the loadout script - is this issue caused by running the loadout before all of the players are ingame?

    How on earth does Patrol Ops accomplish this? Is it because everyone is a JIP, so it executes a special set of instructions once that player is in game, vs my mission, which runs everyone at the same time (no JIP or respawn)?

    I found this forum thread that seems to describe the same situation I'm in:

    Has anyone tried this bit of code?

    WaitUntil{isDedicated || not isNull player};
    from here:

    Any solutions that other mission makers use? I know this has been solved, judging from some of the missions out there, particularly the dynamic ones. I may just have to tear apart Domi or Patrol Ops, although I would rather not...
    Last edited by zilfondel; 10-02-2012, 09:49 PM.
    "Anyone who has never made a mistake has never tried anything new."

  • #2
    Re: Loadout editor woes

    Apparently there is a well-known bug using the "restart" & "reassign" server commands:

    I take it that missions must be SHUTDOWN for them to work properly and re-init all of the scripts??
    "Anyone who has never made a mistake has never tried anything new."




    TeamSpeak 3 Server




    Twitter Feed