Announcement

Collapse
No announcement yet.

Version 1.55

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Version 1.55

    Errr, I don't remember doing any updates except for beta patch updates, and now it's saying that I have version 1.55 while all the servers on the list are version 1.54

    What's going on?

    EDIT: Okay, I just looked at the latest beta patcher, and when it updates it says it's updating it to 1.55 , but the one before it updates to 1.54 , so I'm going to see if using the older beta patch works. They must have had some sort of mixup.

Connect

Collapse

TeamSpeak 3 Server

Collapse

Advertisement

Collapse

Twitter Feed

Collapse

Working...
X