Announcement

Collapse
No announcement yet.

TS and mic

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TS and mic

    I just got a new mic the other day and i am still havening the same problems with people not hear me but i have figured out why any sound that comes through my speaker on my headset is heard threw my my mic when i talk therefor u cant hear me and u hear static but no matter how low i set my speakers it does not help so if u guys have any idea how to fix this problem i would really appreciate it thx.

  • #2
    Re: TS and mic

    Yeah I know I get about 30 seconds of useful information from you a night. the rest is all static. You're a great team player it would be nice if we could hear you.
    1st, make sure you are using the "Push to talk" option instead of voice activation. This reduces background issues. Make sure your mic cable isn't wrapped around something that could be giving feedback. Also make sure your mic isn't getting feedback from your speaker setup. Maybe turn them down real low just to test.
    |TG-12th| tHa_KhAn

    XBL GT: Khan58

    Comment


    • #3
      Re: TS and mic

      Check these settings and see if they do anything. I know you don't have an echo but could produce some insight into the issue.
      __________________________________________________ ____________________________
      A:
      There basicly are two ways echos can occur:

      * Sound from your speakers/headphones being recorded by your microphone.
      * Your sound driver recording all sound that you hear for you.

      Now, 'which one do I have' you might be asking yourself... You can find out quite easily: Just turn your speakers/headsets off (volume = 0%), and ask your mates if you are still echoing. If you are not, you got (a); if you are still echoing you have (b).

      Fixing (a):

      This type of echo is nearly impossible to fix completely, but you can minimize it greatly if you follow a few general points:

      * Switch your speakers off when TeamSpeak is on, use a headset to hear.
      * Use headphones that shield well, meaning they prevent as much sound as possible from being audible to the outside.
      * Try and keep your microphone as far away as possible from the headset (or more general, the sound-source).
      * Lower the volume of the sound-source.

      Fixing (b):

      These echos are produced by your sound-drivers, they should be configurable by your driver too (its not a bug, its a feature). From windows users we have often heard you can select from which devices to record in the mixer (a mixer is the place where you can slide all these volume controls). Make sure the microphone is the only entry that is being recorded from. How exactly this is called, and where exactly you can find it depends on your driver/OS combination, you just have to search around. Good luck.

      __________________________________________________ __________________________________
      If you have dual cores, you might want to try this.


      Ok, so I was one of the many people experiencing static after playing games like Battlefield 2142. Eventually, whenever I would talk I would produce a loud static noise. It was random in its occurrence, but it would always happen. I couldn't use Teamspeak and play BF2142 reliably. The forums here were no help with solution so I did my own testing.

      My system:

      Asus M2N-SLI Deluxe
      AMD 64x2 4600+
      Windows XP
      using onboard audio with latest soundmax drivers


      The solution for me, was to assign battlefield 2142 and teamspeak to separate cores on the processor. You go to task manager, right click the process, and assign an affinity. I chose core 0 for battlefield and core 1 for teamspeak. I have been playing for two days now with no issues whatsoever. So it is one extra step for me when playing battlefield, but at least I can use the comm!

      I'm not sure if everyone else that was having the problem had a dual core, but this totally fixed it for me. So hopefully this helps someone in the future! Maybe the developers could look into it also.


      __________________________________________________ __________________________________
      Lastly, try recording something in windows sound recorder and see how it sounds. Make sure to record 2-3 minutes and play it back. Just read from a book or talk gibberish.

      Also, check your codec that you are using in teamspeak. Doubt that is a problem but could be.

      Lastly, run a dxdiag on your direct sound and see if all the tests pass. Could be an issue with direct input and teamspeak.

      Comment


      • #4
        Re: TS and mic

        Originally posted by deathknight View Post
        Check these settings and see if they do anything. I know you don't have an echo but could produce some insight into the issue.
        __________________________________________________ ____________________________
        A:
        There basicly are two ways echos can occur:

        * Sound from your speakers/headphones being recorded by your microphone.
        * Your sound driver recording all sound that you hear for you.

        Now, 'which one do I have' you might be asking yourself... You can find out quite easily: Just turn your speakers/headsets off (volume = 0%), and ask your mates if you are still echoing. If you are not, you got (a); if you are still echoing you have (b).

        Fixing (a):

        This type of echo is nearly impossible to fix completely, but you can minimize it greatly if you follow a few general points:

        * Switch your speakers off when TeamSpeak is on, use a headset to hear.
        * Use headphones that shield well, meaning they prevent as much sound as possible from being audible to the outside.
        * Try and keep your microphone as far away as possible from the headset (or more general, the sound-source).
        * Lower the volume of the sound-source.

        Fixing (b):

        These echos are produced by your sound-drivers, they should be configurable by your driver too (its not a bug, its a feature). From windows users we have often heard you can select from which devices to record in the mixer (a mixer is the place where you can slide all these volume controls). Make sure the microphone is the only entry that is being recorded from. How exactly this is called, and where exactly you can find it depends on your driver/OS combination, you just have to search around. Good luck.

        __________________________________________________ __________________________________
        If you have dual cores, you might want to try this.


        Ok, so I was one of the many people experiencing static after playing games like Battlefield 2142. Eventually, whenever I would talk I would produce a loud static noise. It was random in its occurrence, but it would always happen. I couldn't use Teamspeak and play BF2142 reliably. The forums here were no help with solution so I did my own testing.

        My system:

        Asus M2N-SLI Deluxe
        AMD 64x2 4600+
        Windows XP
        using onboard audio with latest soundmax drivers


        The solution for me, was to assign battlefield 2142 and teamspeak to separate cores on the processor. You go to task manager, right click the process, and assign an affinity. I chose core 0 for battlefield and core 1 for teamspeak. I have been playing for two days now with no issues whatsoever. So it is one extra step for me when playing battlefield, but at least I can use the comm!

        I'm not sure if everyone else that was having the problem had a dual core, but this totally fixed it for me. So hopefully this helps someone in the future! Maybe the developers could look into it also.


        __________________________________________________ __________________________________
        Lastly, try recording something in windows sound recorder and see how it sounds. Make sure to record 2-3 minutes and play it back. Just read from a book or talk gibberish.

        Also, check your codec that you are using in teamspeak. Doubt that is a problem but could be.

        Lastly, run a dxdiag on your direct sound and see if all the tests pass. Could be an issue with direct input and teamspeak.
        Hey man thx for all those tips i got the problem fix now.

        Comment


        • #5
          Re: TS and mic

          sweet post what you did bro if you can for anyone else who is having the problem

          Comment

          Connect

          Collapse

          TeamSpeak 3 Server

          Collapse

          Advertisement

          Collapse

          Twitter Feed

          Collapse

          Working...
          X