Announcement

Collapse
No announcement yet.

System freezing, audio loop?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • System freezing, audio loop?

    I know I'm not the first person to have issues with Arma so I'm hoping I can get some direction on what to do.

    I can play Arma usually for an hour or so and then my game will just freeze and the audio will loop. Usually the audio will progress a little and then loop. Sometimes the audio will go back to normal for 10 seconds and I can use TS but the game is still frozen. I can't always alt+tab out and usually have to do a hard restart of my system. I don't get BSOD's the game just freezes. This doesn't always happen but it is frequent.

    I believe I have up to date drivers for everything but I could be wrong.

    System:
    - AMD 64 3700 (o.c. to 2.9GHz, has been stable like this for almost a year or more, no problems in other games or stability tests)

    - 2x1GB OCZ Platinum (not running 1:1, slightly less then the fsb, again stable in all other games and tests)

    - Audigy 2 (I have a feeling this could be the culprit. Card is several years old now but the Xi-Fi seem to have problems as well. Driver is from 2006, I have heard there is a newer one but can't find it? I have dissabled EAX in game, hardware accel is on)

    - 8800GTS 640mb (driver is 167.xx, have had this problem with previous drivers, will be updating to 169.xx soon. Freeze up occurs regardless of overclocking)

    I have update the openAL drivers and new directX. I run the FDF sound mod, true view, and arma effects. I use Team speak and team speak overlay. TS overlay I have heard can cause problems, any info on this?

    This is frustrating becuase the computer is not crashing, the game freezes and doesn't allow me to alt+tab out to shut it down. Would the -maxmem 512 help?
    Any help would be greatly appreciated.

  • #2
    Re: System freezing, audio loop?

    I always recommend maxmem regardless.

    The first step I would try is to play without TeamSpeak Overlay or any mods and see if the problem repeats. If it does, I recommend you check your arma.RPT file immediately after crashing or having to hard boot and before restarting the game. It can usually be found here:

    C:\Documents and Settings\username\Local Settings\Application Data\ArmA

    Here is the BIKI page that explains how it works:

    BIKI arma.RPT

    The last couple of lines should say what ArmA was doing (or what caused it to crash) when the problem occurred. I am happy to look at the last couple of entries as well to help diagnose if you want to send them to me via pm or e-mail.

    If it is something game resource or mission related we can look further into that. If not we can look at possible issues with your system.

    There is also a great thread at the BIS forums to check out:

    Hardware Issues: Tips/Tricks/Solutions
    LoyalGuard

    Comment


    • #3
      Re: System freezing, audio loop?

      My loops and freezes stopped when I updated to the latest nvidia motherboard drivers. Then I reinstalled Windows without the mobo drivers (using the windows PCI and IDE drivers) and now there is just a brief stutter.
      Not using OpenAL, sound mods, true view, and TSO (just TS)

      Comment


      • #4
        Re: System freezing, audio loop?

        Thanks for the replies guys. I tried finding the Arma.rpt file this morning before work but could not locate it. I will try to find it tonight. I have been doing some reading at the BIS forums and it seems that the 8800 cards seem to have alot of issues with vram causing crashes which could be what is up with my system. I will try playing around with the -maxmem as well using the flush command.

        Loyal I will try your systematic approach and see if anything shows up. I have grown accustomed to the mods now and really don't wan't to have to give any up : ). The TS overlay is very handy as well. However crashing in the middle of an attack trumps the benefits of all the mods.

        Comment


        • #5
          Re: System freezing, audio loop?

          I've disabled all my mods, added maxmem, updated drivers, followed most of the suggestions in that discussion...still crashing. I'm thinking my issues are deeper than ArmA right now. It's making me crazy!
          | | |

          Comment


          • #6
            Re: System freezing, audio loop?

            Originally posted by Atomic Dog View Post
            I've disabled all my mods, added maxmem, updated drivers, followed most of the suggestions in that discussion...still crashing. I'm thinking my issues are deeper than ArmA right now. It's making me crazy!
            What kind of crashes?


            Originally posted by Long Bow View Post
            I know I'm not the first person to have issues with Arma so I'm hoping I can get some direction on what to do.
            I can play Arma usually for an hour or so and then my game will just freeze and the audio will loop. Usually the audio will progress a little and then loop. Sometimes the audio will go back to normal for 10 seconds and I can use TS but the game is still frozen. I can't always alt+tab out and usually have to do a hard restart of my system. I don't get BSOD's the game just freezes. This doesn't always happen but it is frequent.
            This really sounds like overheating. Have you tried it without the OC on your CPU & Mem. I was having beaucoup problems with ArmA when I was overclocking, despite not having any problems with other software (even with temps in reasonable ranges).

            Definitely upgrade to the new nvidia drivers....they work awesome!

            There is definitely bad blood between creative & ArmA. There was a new Audigy driver released on October 9th: http://us.creative.com/support/downl...pe=0&x=12&y=10

            Definitely use the maxmem command, and if you have macros on your keyboard, program in the flush routine. I flush whenever there is a break in the action.
            Last edited by Brewski; 11-01-2007, 11:47 AM. Reason: added some info

            Comment


            • #7
              Re: System freezing, audio loop?

              I get in game for a good 5-10 minutes then suddenly everything locks up and the audio stutters so fast it sounds like a constant note. I'm unable to alt-tab, win key, or ctrl-alt-del to get out of it. The only thing I can do is to reboot my computer which sometimes sends me into a violent loop of reboots (which seems to be an unrelated problem, I've been dealing with this one for some time).

              Also, this just started recently. I just found two more updates for my video and audio drivers on windowsupdate...I'm about to see if that fixed anything.
              | | |

              Comment


              • #8
                Re: System freezing, audio loop?

                Originally posted by marstein View Post
                My loops and freezes stopped when I updated to the latest nvidia motherboard drivers. Then I reinstalled Windows without the mobo drivers (using the windows PCI and IDE drivers) and now there is just a brief stutter.
                Not using OpenAL, sound mods, true view, and TSO (just TS)
                Arma uses openAL by default, unless you are starting ArmA with the -dsound parameter (which doesn't work very well).

                I'd strongly suggest installing the updated openAL: http://developer.creative.com/articl...&top=38&aid=46

                and enable EAX....if you have a creative card...it solved many positional sound problems with ArmA

                Comment


                • #9
                  Re: System freezing, audio loop?

                  Originally posted by Atomic Dog View Post
                  I get in game for a good 5-10 minutes then suddenly everything locks up and the audio stutters so fast it sounds like a constant note. I'm unable to alt-tab, win key, or ctrl-alt-del to get out of it. The only thing I can do is to reboot my computer which sometimes sends me into a violent loop of reboots (which seems to be an unrelated problem, I've been dealing with this one for some time).

                  Also, this just started recently. I just found two more updates for my video and audio drivers on windowsupdate...I'm about to see if that fixed anything.
                  Have you ruled out heat?

                  Comment


                  • #10
                    Re: System freezing, audio loop?

                    There's no winning...updating my directx has now borked my TSO. It's telling me my directx isn't installed correctly. Ugh.
                    | | |

                    Comment


                    • #11
                      Re: System freezing, audio loop?

                      Originally posted by JAMerica View Post
                      Have you ruled out heat?
                      I haven't really ruled out anything. I'm not the savviest at tech stuff. Just pretty damn lucky most of the time.
                      | | |

                      Comment


                      • #12
                        Re: System freezing, audio loop?

                        Originally posted by Atomic Dog View Post
                        I haven't really ruled out anything. I'm not the savviest at tech stuff. Just pretty damn lucky most of the time.
                        The most simple thing to do is just open your case and blow the dust out with compressed air. It's amazing how dust can cake into the cpu/gpu fans.

                        As for TSO...there should be an option under the debug tab where you can choose "alternative directx method" and give that a shot. If not reinstalling it should fix it.

                        Comment


                        • #13
                          Re: System freezing, audio loop?

                          usually freezes such as the one your describing happen because you have 2 hardware components sharing the same IRQ. usually on your motherboard you have the AGP/PCI-E slots then 4-5 pci slots. each one is set a certain IRQ by ACPI. i think pci slot 2 and the agp/PCIe slot share the same IRQ. after making sure that there is nothing driver related going on try swapping out your audio card to another pci slot. also updated mobo driver and audio/video drivers. an easy way to check for an IRQ conflict is look in your device manager under your control panel.

                          go to view and select view resources by connection.

                          expand the interrupt request(IRQ) tab

                          now look under PCI and make sure there are no SEPERATE pieces of hardware using the same IRQ number.

                          if you need i can give you a screenshot of mine to show how its supposed to look.

                          All the USB stuff on the same IRQ is fine but you want everything else on seperate IRQ's.

                          also with creative cards the PCI latency in your bios can have a big effect too.

                          try setting it progressively higher from 128 and see if that helps. first make sure of no IRQ conflicts though.

                          Comment


                          • #14
                            Re: System freezing, audio loop?

                            Everything is on seperate IRQs, save the USB stuff.
                            | | |

                            Comment


                            • #15
                              Re: System freezing, audio loop?

                              I will be trying to tune my overclock down a bit but I have had no problems up until now. I have run a good deal of stability programs, bought a DFi Lanparty mobo, good quality psu and ram etc. Overclocking as the goal from the very begining of this build up. Temperatures are safe as for my cpu (aftermarket cooling) and gpu as well.


                              Atomic I sometimes get that directx error with TSO. It seems to be sensitive to what order you launch it in. If I alt tab out of Arma and try to launch it I usually get that error.

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X