Announcement

Collapse
No announcement yet.

Laggy mouse/KB input

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Laggy mouse/KB input

    I seem to be having some issues in GRAW, It's almost like online latency.. But worse;

    For example, I'll hit "W" which is bound as the forward key, and 4-5 seconds later I'll get movement, if I hold the key.. I'll move for 30-60 seconds without my finger on the key. It makes the game unplayable, No issues in any-other game.

    Does anyone have any information or insight into my problem?

    ATi Radeon9800XT 256MB
    AMD64 3200+ @2.4GHZ
    1024MB Corsair XMS Ram @stock timings

  • #2
    Re: Laggy mouse/KB input

    Hey antihexe! Welcome to TG!

    I have a 9800XT as well...running an Intel 3.4GHz with 2GB RAM.

    One thing I did to help the mouse lag was to install ATI tray tools and set the "Flip Queue Size" to 2 (it was previously set at 0). This is similar to the Nvidia's max frames to render ahead setting. ATI Tray tools allows you to tweak settings you can't get at with the Catalyst Control Center. A setting of '0' is supposed to give hyperthreading CPU's a bit of a headache (mine is) so that seemed to help alot.

    Try these tweak guides as well:

    GRAW Tweak Guide

    and

    ATI Tweak Guide

    Using both of these guides, I've significantly improved my frame rates, though it's still not perfect.

    I've done the following:

    1) Updated ATI Catalyst to v6.5
    2) Updated my motherboard drivers
    3) Played with the GRAW settings in the main config file

    I also got a new soundcard and dumped my onboard sound. I should have done this ages ago, but kept putting it off simply because I never had a problem before GRAW. Got an Audigy card. If you're running onboard sound, I'd seriously consider buying a sound card.

    Hope this helps. I'm not sure about the keyboard bit, but I bet its related to general gameplay lag due to overtasking your system.
    |TG| HOUDINI






    Comment


    • #3
      Re: Laggy mouse/KB input

      Originally posted by houdini
      Hey antihexe! Welcome to TG!

      I have a 9800XT as well...running an Intel 3.4GHz with 2GB RAM.

      One thing I did to help the mouse lag was to install ATI tray tools and set the "Flip Queue Size" to 2 (it was previously set at 0). This is similar to the Nvidia's max frames to render ahead setting. ATI Tray tools allows you to tweak settings you can't get at with the Catalyst Control Center. A setting of '0' is supposed to give hyperthreading CPU's a bit of a headache (mine is) so that seemed to help alot.

      Try these tweak guides as well:
      *

      and
      *

      Using both of these guides, I've significantly improved my frame rates, though it's still not perfect.

      I've done the following:

      1) Updated ATI Catalyst to v6.5
      2) Updated my motherboard drivers
      3) Played with the GRAW settings in the main config file

      I also got a new soundcard and dumped my onboard sound. I should have done this ages ago, but kept putting it off simply because I never had a problem before GRAW. Got an Audigy card. If you're running onboard sound, I'd seriously consider buying a sound card.

      Hope this helps. I'm not sure about the keyboard bit, but I bet its related to general gameplay lag due to overtasking your system.
      Thanks a lot, I've done most of that, with the exception of the drivers (I use omega drivers, since I get a big boost in performance usually)...

      And as for the keyboard lag, I don't think it has much to do with overtaxing my system, i've set it as low as possible, it just wont work correctly. I do have onboard sound, and I haven't had an issue with it so far, but I am curious as to what issue you had with your onboard.

      The mouse lag, I have heard of and I did get that cleared up.

      Comment


      • #4
        Re: Laggy mouse/KB input

        do you have the latest version?

        Comment


        • #5
          Re: Laggy mouse/KB input

          You know, it could be something as "simple" as onboard sound. For me, everything was working fine (keyboard, etc) but the mouse lag was killing me. It took forever to aim precisely. After tweaking and adding the sound card, the mouse lag is still present, but very slight. I attribute that to the 9800XT being slightly underpowered. I'm currently debating whether or not to spend some cash on an AGP X850XT before building a new Vista-centric computer with PCI-Expess and all that jazz.

          Perhaps you could try disabling your sound and see if that improves things. Other than that, the only thing I can think of is to check your running processes...maybe you've got something going on in the background. Is your keyboard always lagging? Online, single player, or both?
          |TG| HOUDINI






          Comment


          • #6
            Re: Laggy mouse/KB input

            Mouselag can be eliminated by setting "max frames render ahead" to 0.

            Give it a shot.

            Comment


            • #7
              Re: Laggy mouse/KB input

              Originally posted by BHack
              Mouselag can be eliminated by setting "max frames render ahead" to 0.

              Give it a shot.
              Like I said, I got that cleared up. Everything is really fine-tuned, i've got under 19 processes. The FPS is actually quite nice, and my PC has run everything (Oblivion, even at max settings at a respectable 19-24 fps outdoors and 40-60 indoors.

              I've got the latest version of the game, it's all patched up.. It just hates me :(

              The lag is present in online and offline, the severity of it doesn't seemto vary at all. I've disabled my onboard sound, nothing has changed. I've tried freeing up my PCI cards, still no change.

              Comment


              • #8
                Re: Laggy mouse/KB input

                USB keyboard? If so, try another "regular" keyboard if you can...you know, that regular keyboard connector on your motherboard.

                Other than that...I'm at a loss. Sorry bud.
                |TG| HOUDINI






                Comment


                • #9
                  Re: Laggy mouse/KB input

                  Here's some more info...the latest patch (1.10) supposedly took care of this problem:

                  GRAW will no longer run as process priority "High", resolving keyboard problems
                  I assume you're all patched up...if so, try this link to the Ubisoft forums. It's a search query for "keyboard lag". At the very least, it'll give you some ideas.

                  UbiSoft forum search

                  Cheers
                  |TG| HOUDINI






                  Comment


                  • #10
                    Re: Laggy mouse/KB input

                    I had this problem in the older version of GRAW. Once I patched up, the keyboard lag problem (running in high priority) was solved. However for me, it created a new problem where I can't get a ping better than 300 ingame (NOT an ISP/network problem).

                    Good luck with your issues, this game is full of them. Good news is the devs are working hard to get the game playable.

                    Comment

                    Connect

                    Collapse

                    TeamSpeak 3 Server

                    Collapse

                    Advertisement

                    Collapse

                    Twitter Feed

                    Collapse

                    Working...
                    X