Announcement

Collapse
No announcement yet.

Anti Alaising (AA)?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anti Alaising (AA)?

    OK, I have my perimeters all set in my desktop shortcuts to start up BF2 and PR with widescreen and to sign ion and all the other junk such as eliminating the start up movies as well. My question is I want to have AA turned on in game or at least try it on like a 4x or possbly 8x, how can I do this cause I had tried setting it in the video options and it automatically gets turned back to "OFF" when I restart PR. Is there a way of adding this to the desktop shortcuts or some other way?
    I may end up turning it back off anyway, I just want to see if there will any difference in my graphics with it on. I normally run about 99 FPS or higher with everything else on high except for textures(medium for that) so sure it wouldn't hurt my FPS to much if it was turned on.
    I wanted to get rid of some of that tearing effect I have.

  • #2
    Re: Anti Alaising (AA)?

    Tearing effect? The software provided by nVidia/ATI should have a VSYNC option. Turn this on to prevent tearing.

    Edit: Hah, Vivid! Beat ya!
    Waldo II

    Comment


    • #3
      Re: Anti Alaising (AA)?

      Originally posted by msdz View Post
      OK, I have my perimeters all set in my desktop shortcuts to start up BF2 and PR with widescreen and to sign ion and all the other junk such as eliminating the start up movies as well. My question is I want to have AA turned on in game or at least try it on like a 4x or possbly 8x, how can I do this cause I had tried setting it in the video options and it automatically gets turned back to "OFF" when I restart PR. Is there a way of adding this to the desktop shortcuts or some other way?
      I may end up turning it back off anyway, I just want to see if there will any difference in my graphics with it on. I normally run about 99 FPS or higher with everything else on high except for textures(medium for that) so sure it wouldn't hurt my FPS to much if it was turned on.
      I wanted to get rid of some of that tearing effect I have.
      If you want to get rid of tearing, you need to enable VSync in your graphics card control panel, however this limits your frame rate to your monitor's maximum refresh rate. However, there are programs that force Triple Buffering and make it so that there's no limit in FPS when Vsync is on.

      For me, I have to try to set it to 8x, then it'll ask me to restart my game. Then I'll try again, and it'll show that it's set on 8x, but asks me to restart my game once again. Then it finally works for sure.

      Another thing you could do is go to your battlefield folder in your documents. Default:

      C:\Documents and Settings\[Username]\My Documents\Battlefield 2\Profiles\0001 (Number of your profile, so for example, if you go to your log in screen, and log in to the first account in the list, leave it at 0001, if it's the second account in the list, change it to 0002)

      Then, double click on your Video.con file. If it asks what you want to open this file with, select Notepad.

      Find the line 'VideoSettings.setAntialiasing'

      Then change the text following the text to '8Samples' for 8x AA, '4Samples' for 4x AA, '2Samples' for 2x AA.

      Then save and you should be good to go.

      Comment


      • #4
        Re: Anti Alaising (AA)?

        Alright Vivid, that sounds like what I was asking for. I had tried numerous times in game to set the AA option then exit game and each time I restarted the game it was "OFF". Have no idea why it won't take, now for the Vsync, what if this won't set or turn on, can you tell me how to set it in the file as well. Seems like I have so many problems with my options for audio and sound not working properly or staying set for some reason.

        EDIT:
        It apparently must have set but not appearing in the options as set. In the video file it is already set to 8samples(8X).

        Comment


        • #5
          Re: Anti Alaising (AA)?

          Originally posted by msdz View Post
          Alright Vivid, that sounds like what I was asking for. I had tried numerous times in game to set the AA option then exit game and each time I restarted the game it was "OFF". Have no idea why it won't take, now for the Vsync, what if this won't set or turn on, can you tell me how to set it in the file as well. Seems like I have so many problems with my options for audio and sound not working properly or staying set for some reason.

          EDIT:
          It apparently must have set but not appearing in the options as set. In the video file it is already set to 8samples(8X).
          Are you running an ATI or Nvidia graphics card?

          EDIT:
          Did you make sure you applied the setting to the correct profile?

          Comment


          • #6
            Re: Anti Alaising (AA)?

            Nvidia 8800GT
            I only have the "Default" and "0001" folders there.

            Comment


            • #7
              Re: Anti Alaising (AA)?

              Start > All Programs > NVIDIA Corporation > NVIDIA Control Panel > Control Panel

              On the left side, click on 'Manage 3D settings'

              Scroll all the way down and you should see 'Vertical Sync'

              Click on it, and make sure it's set to 'Force on'

              Comment


              • #8
                Re: Anti Alaising (AA)?

                Alright, I got that set to "Force On". BTW I have informed you I am on Vista and had to go into Control Panel>Hardware and Sound>Nvidia Control Panel

                Comment


                • #9
                  Re: Anti Alaising (AA)?

                  Originally posted by msdz View Post
                  Alright, I got that set to "Force On". BTW I have informed you I am on Vista and had to go into Control Panel>Hardware and Sound>Nvidia Control Panel
                  Ok, shouldn't make a difference.

                  Comment


                  • #10
                    Re: Anti Alaising (AA)?

                    The following a statement of opinion:

                    Anti-aliasing sucks. I would much rather have a couple jaggies than have my long-distance targets get blurred to hell (Yes, I understand the concept of AA and how it is not technically blurring).

                    Personally, I'd recommend a max of 2x MSAA.

                    Comment


                    • #11
                      Re: Anti Alaising (AA)?

                      I want to try it to see if there is any difference anyway for myself. I may take it off after I see how it is.

                      Comment


                      • #12
                        Re: Anti Alaising (AA)?

                        Originally posted by Riffraffselbow View Post
                        The following a statement of opinion:

                        Anti-aliasing sucks. I would much rather have a couple jaggies than have my long-distance targets get blurred to hell (Yes, I understand the concept of AA and how it is not technically blurring).

                        Personally, I'd recommend a max of 2x MSAA.
                        I find it makes everything sharper and prettier.

                        Comment


                        • #13
                          Re: Anti Alaising (AA)?

                          Originally posted by Riffraffselbow View Post
                          The following a statement of opinion:

                          Anti-aliasing sucks. I would much rather have a couple jaggies than have my long-distance targets get blurred to hell (Yes, I understand the concept of AA and how it is not technically blurring).

                          Personally, I'd recommend a max of 2x MSAA.
                          Hmm, sounds like you don't actually understand the concept of AA, then. ;) I run 16xAA at 1680x1050.
                          TG5th USARMY||JeonJiHyeon

                          Comment


                          • #14
                            Re: Anti Alaising (AA)?

                            Yep vivid had it. Set it to your AA preference, click apply, it will stay on off, restart game, try again, it will go to that preference, restart, then it should work. I find that 4x AA is good and anything 8x or above is just throwing away your frames for miniscule visual difference.


                            Comment


                            • #15
                              Re: Anti Alaising (AA)?

                              Never mess with in-game filtering options, as sometimes these are rarely the most efficient. Your best bet is to always use your video card's settings, whether that be Nvidia's settings or ATI's control panel.

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X