Announcement

Collapse
No announcement yet.

Need help installing/patching BF2 on Win7 64bit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help installing/patching BF2 on Win7 64bit

    I am trying to installed BF2 on my new PC and I have not been able to get it to work.

    I can get it to run Vanilla BF2 1.0. But as soon as I patch it, it stops working. Now when I run BF2 it will throw the splash screen up and then seems to start. The screen will go black like normal but then it stays black forever. At this point I have to hit ctrl-alt-del and restart the PC to get any control back (it won't kill the bf2.exe process so restarting is the only way). I don't believe the refresh rate is the issue.

    I have installed the game using instructions here: http://forum.ea.com/eaforum/posts/list/15/298698.page

    There is a post near the end of that page that I used. I have tried installing BF2:SF as instructed on that page and I have done it without installing SF.
    Viking

  • #2
    Re: Need help installing/patching BF2 on Win7 64bit

    Have you tried deleting the video.con file?
    sigpic

    Comment


    • #3
      Re: Need help installing/patching BF2 on Win7 64bit

      What buf said solves issues that I have sometimes, similar to this. just to check you've patched to 1.41 before 1.50 right? aybe try a different patch file?
      |TG-69th|chrisweb89


      Comment


      • #4
        Re: Need help installing/patching BF2 on Win7 64bit

        It works fine on 1.0. I then patch it to 1.41 using the patch file on the DVD (BF2 Complete DVD). I have used a patch DL from Gamershell too. I have not tried deleteing the video.com but I have played with the resolution/refresh rate settings in it.
        PS: that didn't work
        Viking

        Comment


        • #5
          Re: Need help installing/patching BF2 on Win7 64bit

          I think I found the issue. I ran it in windowed mode and my security software comes up and asks about changes made to the program ( something I couldn't see running fullscreen). It seems to be working now.
          Viking

          Comment

          Connect

          Collapse

          TeamSpeak 3 Server

          Collapse

          Advertisement

          Collapse

          Twitter Feed

          Collapse

          Working...
          X