Announcement

Collapse
No announcement yet.

Flashing surfaces bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Flashing surfaces bug

    I just installed BF2 and can play the game smoothly, yet there is one bug that seems to be an issue on every map. The ground and surfaces of some structures constantly flash. I don't know how to fix this, and I've tried to update my video driver from www.ati.com, but I just get lost on their website. My video driver is ATI Mobility Radeon 9600 Pro Turbo. Any suggestions?

    Edit: I downloaded and installed Omega 5.7 driver, but now the entire screen goes pitch black off an on as I walk around a map.
    Last edited by the-j; 08-24-2005, 01:57 AM.
    CS:S - |TG|Cpt. Christ
    BF2 - [TG]ikose

  • #2
    Re: Flashing surfaces bug

    Hi J.

    I have the same thing when the temp. of my Graphics Cards seems to overheat, playing for a couple of hours when the room temp. is also high). Does this thing happen after you have played for some time or right at the beginning?
    You could try some different settings (lower your detail) so the card does not run that hot.

    In my case it does not bother me that much, makes me shut of the computer and do other (perhaps more usefull) stuff then playing! ;-)

    I also have an ATI card (740-something) and I'm running the game at some fairly high settings.

    But I can understand your annoyance.

    Hopes it will work out for you.
    Pommetje

    Comment


    • #3
      Re: Flashing surfaces bug

      Originally posted by Bommando
      I used to see this, but now that I got the latest Catalyst update, it has stopped altogether. What's your Catalyst driver version? I think the latest is 5.8.
      Hmmm, Bommando,

      Did you experience this from the start of the game (like J) or when playing for a while (like myself)?

      Marco
      Pommetje

      Comment


      • #4
        Re: Flashing surfaces bug

        I'm using an older set of Omegas with my Mobility 9600. I think they're 5.2's or something. I haven't updated them in a long time.

        - It's who you game with.

        Comment


        • #5
          Re: Flashing surfaces bug

          I got this problem because my video card overheated. I have a Radeon 9800Pro which is a great card but the stock heatsink is lousey. I replaced the stock heatsink with an Arctic Cooling fan ($30) and have since not had the problem. If your mobility card is in your laptop then it is kinda hard to mod it :(

          Comment


          • #6
            Re: Flashing surfaces bug

            I'm going to assume its a heat issue. I know of a mod that helps control the heat from the video card in my particular type of laptop. I'll attempt this mod and give you guys an update. Hope I don't destroy my computer.

            BTW, www.notebookforums.com has excellent mods for your laptop. I've done the keyboard fix for my Dell Inspiron 8600, keyboard works perfectly now.
            CS:S - |TG|Cpt. Christ
            BF2 - [TG]ikose

            Comment


            • #7
              Re: Flashing surfaces bug

              Originally posted by the-j
              I'm going to assume its a heat issue. I know of a mod that helps control the heat from the video card in my particular type of laptop. I'll attempt this mod and give you guys an update. Hope I don't destroy my computer.

              BTW, www.notebookforums.com has excellent mods for your laptop. I've done the keyboard fix for my Dell Inspiron 8600, keyboard works perfectly now.
              I had the exact same issues you were describing above with my drivers (very old, but newest for my specific model of graphics card). I had traced it down to the fact that they flash when a building is being hit by gunfire of any kind etc.

              I upgraded my graphics drivers to 5.7 (tried Omega and official ATI) and had severe problems, game lockups, reboots, etc. I downgraded to 5.6 and have some, but not as many, problems. I have not yet upgraded to 5.8 as I was afraid it would have the same issues as 5.7, but since Bommando has tried and had no problems, I'm going to try it.

              I too however, thought it was heat related. I have software that controls the fan on my GPU, and switched it from smart-controled (which ran it consistantly around 2500 rpm) to a manually controlled 3000 rpm. It didn't have any change, so I maxed it out around 4500 rpm, still no change, and then I tried playing with the drivers etc. I can pretty much promise you that it's not heat as my fan settings had no effet, and my GPU temps were solidly in the 40's.

              Comment


              • #8
                Re: Flashing surfaces bug

                Well I completed the heat mod, and the problem is still here. I tried upgrading to 5.8, but it says a video driver could not be found.

                Edit: I'll post some screen shots of what the game looks like while playing.
                CS:S - |TG|Cpt. Christ
                BF2 - [TG]ikose

                Comment


                • #9
                  Re: Flashing surfaces bug

                  Tip: Remove your video drivers before installing the new ones.

                  Sometimes doing this can help avoid conflicts with the old drivers.

                  Comment


                  • #10
                    Re: Flashing surfaces bug

                    Good idea. I'm trying to find out where to unistall my driver. Where do I go?

                    Edit: here's a pic of what my game looks like. Note: the sky in the background is black, sometimes my whole screen turns black like that. This typically happens after I die once.
                    http://www.solisearch.net/ims/pic.ph...Nj5th&i=191390
                    CS:S - |TG|Cpt. Christ
                    BF2 - [TG]ikose

                    Comment


                    • #11
                      Re: Flashing surfaces bug

                      To remove ATI video drivers, go Start->Control Panel->Add or Remove Programs->Locate and click on ATI Control Panel->Click change/remove. Once that is complete, in the same Add Or Remove Programs area, locate and click on ATI drivers (something like that), click change/remove, click select all, click ok. When done, restart system (should ask you).

                      When system starts up and says "New hardware found" click cancel. You will have to do this twice. Locate the Catalyst drivers you downloaded, double click and follow instructions.
                      [age-c1][tog-c1][volun]

                      Comment


                      • #12
                        Re: Flashing surfaces bug

                        Originally posted by FishRoy
                        Tip: Remove your video drivers before installing the new ones.

                        Sometimes doing this can help avoid conflicts with the old drivers.
                        I unistalled my driver and reinstalled it. I think it fixed the problem...! Thankyou everyone for your help.
                        CS:S - |TG|Cpt. Christ
                        BF2 - [TG]ikose

                        Comment

                        Connect

                        Collapse

                        TeamSpeak 3 Server

                        Collapse

                        Advertisement

                        Collapse

                        Twitter Feed

                        Collapse

                        Working...
                        X