Announcement

Collapse
No announcement yet.

ATI 9800 Pro users

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI 9800 Pro users

    Hey all

    Just updated my drivers to 5.13 (latest on ATI's site) and im experiencing a bunch of video errors. Im getting what looks like texture errors and ghosting.

    Im going to reinstall an older driver and start trouble shooting but im simply curious if anyone else ran into any similar issues.
    Thanks to Tactical Gamer...Im still unemployed

  • #2
    Re: ATI 9800 Pro users

    I have one but didn't install the new drivers and not going to after reading this :p. My philosophy with video drivers is if everything's still working, don't update.

    Comment


    • #3
      Re: ATI 9800 Pro users

      you can try the omega drivers they are pretty good. I have had similar problems with the catalyst drivers and BF2. I run a radeon sapphire atlantis 9600.
      sigpic

      Comment


      • #4
        Re: ATI 9800 Pro users

        If you use Omega drivers Teamspeak overlay doesn't work, I'm still on 5.12

        Comment


        • #5
          Re: ATI 9800 Pro users

          i had a bunch of problems with my x800xl, started using the Omega drivers and all seems well. Just remember to ust the uninstall utility from ATI so you dont miss anything.

          Sarcoma
          Sarcoma.

          Comment


          • #6
            Re: ATI 9800 Pro users

            Just out of curiosity - those with 9800 Pros, what framerates do you get on BF2 and what are your specs? My rig:
            AMD 2600+
            1.5 gig DDR-333 RAM (running at 333 instead of 400 due to the extra stick)
            ATI 9800 Pro, 256 megs
            Run it at 1024x768 on my LCD TV
            Most settings on medium, rest on low with dynamic lighting on low
            I get at most 45 fr/sec, usually around 25, dipping to 12-18 on some bigger maps.

            This is odd because I ran my old AIW 9700 Pro (128 meg) at 800x600 with medium settings and 4x AA and it ran super smooth.

            Not sure what version drivers I'm using - I think 5.12.
            Beatnik

            Comment


            • #7
              Re: ATI 9800 Pro users

              I'm still using 5.11, haven't tried out 5.13 yet.

              My system specs:
              AthlonXP 2500+
              1GB DDR333 RAM
              ATI 9800pro, 128MB
              1024x768 resolution, windowed mode
              low graphics settings

              My framerates vary from below 5fps on some city maps to 25ish on big, open maps. Usually it hovers around 14-17fps plus occasional freezes.

              It seems like each patch slows down my framerate more. Needless to say, it's quite annoying and frustrating.



              TacticalGamer TX LAN/BBQ Veteran

              Comment


              • #8
                Re: ATI 9800 Pro users

                I have an athlon 2700+ 1gig ram radeon 9800pro 256mb and I get 45+ FPS everywhere with all low/lighting off settings at 1024x768

                Comment


                • #9
                  Re: ATI 9800 Pro users

                  Originally posted by Beatnik
                  Just out of curiosity - those with 9800 Pros, what framerates do you get on BF2 and what are your specs? My rig:
                  AMD 2600+
                  1.5 gig DDR-333 RAM (running at 333 instead of 400 due to the extra stick)
                  ATI 9800 Pro, 256 megs
                  Run it at 1024x768 on my LCD TV
                  Most settings on medium, rest on low with dynamic lighting on low
                  I get at most 45 fr/sec, usually around 25, dipping to 12-18 on some bigger maps.

                  This is odd because I ran my old AIW 9700 Pro (128 meg) at 800x600 with medium settings and 4x AA and it ran super smooth.

                  Not sure what version drivers I'm using - I think 5.12.
                  your processor is a bottleneck, beatnik. i got good gains going from an athlon 1700+ (at about 2Ghz, mind you) to an A64 3000.

                  running the aforementioned A64 with 1GB of memory, i was getting similar performance as your, possibly a little better. top few settings (including texture) on medium, others on low, 4x AA, 1024x768.

                  i only had a 9800np 128MB, though. i was running at about 390mhz core/300 memory.
                  [TG]epheneh

                  Comment


                  • #10
                    Re: ATI 9800 Pro users

                    I am still on 5.1...I have no plans to update as I have everything working perfectly so why mess with it.
                    |TG-1stMIP| Ransack



                    Comment


                    • #11
                      Re: ATI 9800 Pro users

                      Originally posted by burble
                      your processor is a bottleneck, beatnik. i got good gains going from an athlon 1700+ (at about 2Ghz, mind you) to an A64 3000.

                      running the aforementioned A64 with 1GB of memory, i was getting similar performance as your, possibly a little better. top few settings (including texture) on medium, others on low, 4x AA, 1024x768.

                      i only had a 9800np 128MB, though. i was running at about 390mhz core/300 memory.
                      Yeah that's what I've been thinking. Especially after upgrading my video card and RAM recently for only modest improvements.
                      Beatnik

                      Comment

                      Connect

                      Collapse

                      TeamSpeak 3 Server

                      Collapse

                      Advertisement

                      Collapse

                      Twitter Feed

                      Collapse

                      Working...
                      X