Announcement

Collapse
No announcement yet.

voip

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • voip

    hi there just discovered your server last night and it is feckin deadly spuad playin the way bf2 is ment to be played. i have just a question about voip in bf2 i cant seem to get my mic to work in the game it works fine in teamspeak and when im in the options in bf2 foe the voip set up and put it in test mode it doesnt register my voice input i would really like to get this to work.
    many thanks sculls.

  • #2
    Re: voip

    Sculls,
    Welcome to my world. I can't get my VOIP to work at all, so I come to these forums to listen to what a brilliant time everyone else is having, and then have to go and play on the rancid public servers. The modern tantalus.

    Comment


    • #3
      Re: voip

      notalegend,

      I don't understand how your not getting voip to work, of all odd things in BF2, voip seems to be pretty straightforward.

      are you using a USB mic? If you are I bet that is your problem. USB adds alot of complexity. I suggest you spend the $10 on a normal 1/8in plugged mic. All sound cards have a mic in on the back (pink hole). If you plug it in there, it's pretty much foolproof you will have no problems. There is no 'recognizing' of the hardware or driver issues or what have you. It's straight up, good old fashioned mic in lovin that requires no processor help.

      I think I spent $20 to get a noise cancelling mic headset that I wear around my neck like a collar, it puts the boom right in front of my mouth. Turn up the mic volume in your windows settings (leave boost, OFF) then load up the game.

      I have standard onboard sound with no flashy dolby digital stuff at all, and it works perfect in the game, in teamspeak, and with both going at once.

      Booyah!

      Comment


      • #4
        Re: voip

        My VOIP always cuts out when the map loads. I alt-tab out to my (already opened) sound card setting page, un-mute the mic and I'm good to go. This might be happening to you. I don's use Teamspeak (yet), so I don't know if that changes anything.

        KZ17
        [combat]

        Comment


        • #5
          Re: voip

          Hi Bhack. Thanks for your thoughts - I already have a mic-jack style headset. It come with 2 jacks, but bear in mind that i am using a laptop, so no direct soundcard plug. However, the crucial point is that when i test on xp it works fine. Totally at a loss to explain it - any further ideas? Oh and Kestrel, thanks also, this is one of the many other things I have tried - I alt tabbed out, but none of my audio settings had defaulted to mute. Sigh

          Comment


          • #6
            Re: voip

            thanks for all the input set up a thing with a mic goin in to the input on the back of the pc and it seems to work sort of i tried to play but the server i was on was full of knobs who wouldnt answer back i will keep trying .
            thanks guys
            go on the fightin irish

            Comment


            • #7
              Re: voip

              notalegend:

              I had the same problem with a laptop I was using (Sager NP5720). Unfortunately, I was not able to fix it despite trying everything under the sun. I eventually got a SoundBlaster Live External USB card and it worked fine. Bit of a pain having to lug around the external box, but for $45 I did what I had to do. You might want to try and beg, borrow or steal a PCMCIA sound card and see if that works...but be prepared to pay $90+ for it.

              KZ17
              [combat]

              Comment


              • #8
                Re: voip

                Originally posted by notalegend
                Hi Bhack. Thanks for your thoughts - I already have a mic-jack style headset. It come with 2 jacks, but bear in mind that i am using a laptop, so no direct soundcard plug. However, the crucial point is that when i test on xp it works fine. Totally at a loss to explain it - any further ideas? Oh and Kestrel, thanks also, this is one of the many other things I have tried - I alt tabbed out, but none of my audio settings had defaulted to mute. Sigh
                Thats goofy. Are you absolutely positive its not working? Like, you've got into the mic setup in BF2 and hit TEST MIC and talked and not heard yourself?

                Not working in the game is one thing, but if you can't even hear yourself talk in the setup menu of BF2 then something is wrong with your mic connection.

                Comment


                • #9
                  Re: voip

                  Exactly that. I run Mic Test in XP - the 2 part test, where part 1 has a level meter which moves as I speak, and part 2 where you get a half second delay of your onw voice playback. Both of these work perfectly. Then I launch BF2, go to audio and do the mic test and get nothing. And i alt tab out and check audio settings in XP and nothing is muted. Glad it's not me going bonkers, but incredibly frustrated. Any other thoughts other than taking a big hammer to the whole thing?
                  Thanks again.

                  Comment


                  • #10
                    Re: voip

                    I had the same problem. But then I tried to spoke just before I hit the "Start Microphone test" option. And suddenly I began to hear my voice in my headset. I do not know If it is working in the game thought, because I have not the opportunity to test it yet.

                    Comment


                    • #11
                      Re: voip

                      Originally posted by notalegend
                      Exactly that. I run Mic Test in XP - the 2 part test, where part 1 has a level meter which moves as I speak, and part 2 where you get a half second delay of your onw voice playback. Both of these work perfectly. Then I launch BF2, go to audio and do the mic test and get nothing. And i alt tab out and check audio settings in XP and nothing is muted. Glad it's not me going bonkers, but incredibly frustrated. Any other thoughts other than taking a big hammer to the whole thing?
                      Thanks again.
                      The last thing I can think of is your volume's is low or muted. Double click the speaker icon in your systray. Click options, advanced controls. You need to go through every separate volume level and make sure they are all maxed, especially wav level. Obviously make sure your mic level is maxed and working.

                      I have a feeling you may be muting it somehow and not even know it. Anyway, even if you can't talk, you should still be able to hear fine, which is what is critical on TG. So at least you can still play.

                      Comment


                      • #12
                        Re: voip

                        I've written books about this and I wish EA would just fix it and be done with it. Bhack totally correct in his setup but it is hard to troubles shoot the details because everyone is different - especially when it comes to laptops and whatnot.

                        I'll repeat a few things Bhack mentioned and add a few comments of my own.

                        Run your XP Mic and configuration setup (I know you have already but..) make absolutely sure that the input you are seeing during the calibration is coming from "Mic1" input.

                        Open the BF2 install folder and run the VoIPconfig executable.. you should still see that you have a working Mic - if you don't, back up, turn Boost ON, and try again.. should work.

                        But thats not all! Just because the VoIPconfig works doesn't mean it will work in-game - because for some odd reason, that executable accepts input from all input sources (Mic1, Mic2, Line-in, etc..).. BF2 in-game will only hear input from "Mic1"

                        Now - so you are successful so far? Run the game.. and run 'Test Microphone' in Options.. it should work fine if all those ducks are in a row. If it doesn't work still, try turning on Boost again if you didn't need to before, run the game again and try testing again.

                        If it still won't work.. it's time to look deeper and that will vary from machine to machine.. what you will likely be looking for is whatever is messing up you computer from treating the input you are using for your microphone as "Mic1". For example (I use this because it is the most recent thing I've noticed).. The new Creative Labs cards have a 'FlexJack' that can be either "Mic1" or "Digital Out" - you have to select it's purpose in the software.

                        Other thoughts -
                        Laptops, The side jack may be defaulted to "Mic2" if it is a laptop capable of being 'Docked', this is because the 'Dock' outputs may be defaulted to "Mic1"

                        Sound Cards with auto-sense.. may be misinterpreting their settings, refer to your documentation (if you can find any) for hard-setting the jacks.

                        There is more of course.. but maybe this gets you started. I'm going to stop because the way my screen is set up and it laid out right now, there is this repeating, horrible vision of a fluffy kitten just prior to an unfortunate demise by TV-Guided bomb/missile and it is damaging my psyche.
                        sigpic


                        Comment


                        • #13
                          Re: voip

                          Originally posted by Bhack
                          notalegend,

                          (pink hole). If you plug it in there,

                          Does it make you horny baby?

                          LOLOLOL


                          |TG-Irr|March4revenge
                          Turning into swiss cheese, one bullet at a time.

                          Comment


                          • #14
                            Re: voip

                            notalegend, did you open up the correct ports on your router for voip?

                            Comment


                            • #15
                              Re: voip

                              Don't know if this will fix it, but try changing TS to Software rendering, instead of wave. I could only hear every 3rd word in TS with VoIP turned on, but once I did that, I could hear both cleanly.

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X