Announcement

Collapse
No announcement yet.

Anyone still having choppy lag issues??

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone still having choppy lag issues??

    Ok I've been through just about every lag related issue with my box the past few months. I've had the cable company come out to tweak my signal (which helped that issue a lot). I've upgraded my video card. I've upgraded my system cooling. I've upgraded my memory to 1.5 gigs (though that took my DDR 333 out of dual mode). I've re-installed freakin windows. I still have the worst lag I've experienced playing on the server. I don't have the same lag on other servers late at night, so it could be a network traffic issue... Here are the symptoms:

    Frequent "Connection is Interrupted" messages.
    The frame will freeze, and I'll be turned anywhere from 90 to 180 degrees when it unfreezes. This makes running in a straight line VERY hard.
    I'll get the herky jerkies often, stutterstepping everywhere.

    It's so bad I'm getting more kills with hand grenades than assault rifles. The game as-is is nearly unplayable.

    What could be causing this, and what can I do to test it?? It's definitely not the video card (ATI x850). And I've updated pbsetup a few times the past couple weeks, and like I was on at 3 am last night with almost no lag issues at all. It was...glorious.
    Beatnik

  • #2
    Re: Anyone still having choppy lag issues??

    I've experienced what you're talking about a little more than usual lately. What I've attributed it to is my wireless connection. The access point is relatively far from the router and will sometimes fluctuate in signal strength and I'm guessing that's when the "connection problems" come up. I don't know if that will apply to you though, I don't know if you have a router. But if you do I would check the connections for whatever is connecting it.

    Comment


    • #3
      Re: Anyone still having choppy lag issues??

      Beatnik, I've been encountering more lag then usual the past week, with symptoms similar to yours. My system isn't near as powerful as yours so I'm wondering it's a routing issue somewhere along the line. I wonder if somewhere near the datacenter we are both hitting a common link.

      Comment


      • #4
        Re: Anyone still having choppy lag issues??

        I have been experiencing horrible problems since about the 18th of December. I receive the "Problem with your connection" multiple times over the course of an evening. My ping stays around 45-50 except when I completely get disconnected. I am running from just north of Philadelphia. Looking at Ping Plotter I get packet loss at either where the server switches from comcast.net to att.net or I get massive packet loss across the board starting at my IP, I guess. From what it looks like to me is that the problem is on my end. Don't really know what else to look at. But to answer Beatnik's question, yes I am experiencing choppy/inconsistent play.

        photographic evidence
        http://www29.homepage.villanova.edu/alexander.cullen/

        Comment


        • #5
          Re: Anyone still having choppy lag issues??

          Do you run Punkbuster updates through the PBweb application? Punkbuster has put out some good sized updates of late and BF2 will download it in the background. If you are having the least bit of network issues this could cause it to snowball.

          I have this stashed in a "clean install notes" file:

          Originally posted by http://www.bf2world.net/bbs/lag-fix-vt609.html

          How to Fix the Lag (Solution here)

          step 1: visit http://www.punkbuster.com/index.php?page=updatepb.php

          step 2: download the exe "pbweb.exe" or download the zip "pbweb.zip". both are found about half way down the page.

          step 3: put the .exe in the pb folder for BF2, found at c:/programfiles/eagames/battlefield2/pb (at least, that's where it is for me).

          step 4: run the .exe---takes a few minutes to finish.

          step 5: save a thousand dollars from not having to buy a new monitor every time you punch the screen in out of frustration.
          Also

          Originally posted by I didn't keep the source but if you're out there thanks
          If you want to have PB and BF2 ready to rock and roll when you want it and not after much waiting:

          - make a shortcut to pbweb.exe
          - edit the shortcut's properties and select : RUN MINIMIZED
          - make a scheduled task that only activates: ON LOGIN

          By the time you think to close the dos window after windows boots, it may have finished updating... thus by the time you peruse your desktop and finally decide on some BF2, it should go straight in with no PB hangups.
          Oh what the hell in case any of this helps:

          I was stuttering to begin with, these posts helped me:

          http://forums.totalbf2.com/showthread.php?t=9734

          and

          http://forums.totalbf2.com/showthread.php?t=8966

          Also, if u wanna max this game out, u are gonna need 2gig ram....[I upgraded to 2gig for this game, helped smooth it out alot]

          finallly make sure net connection is set to DSL and not T1 LAN

          AND do this any time u change graphic settings:

          Clearing Shader Optimizations: At the moment there are times when you change the graphical settings and the demo will not optimize the shaders. This can increase lag/freezes and reduce performance. To ensure you overcome this, change the settings the way you want them then quit the game. Go to your \Documents and Settings\[username]\My Documents\Battlefield 2 Demo\mods\bf2\cache\ directory and delete all the folders underneath it. The next time you start the game and play single or multiplayer, your shaders will be optimized.
          Good luck!

          Comment


          • #6
            Re: Anyone still having choppy lag issues??

            Thanks for the responses guys. I'm going to try all of these recommendations. I'm very close to the datacenter (about 200 miles south in Austin), so I would think a connection issue is unlikely, but who know's I'm using RoadRunner and had problems before... I'll definitely try out pingplotter and see what's what.

            I've been running pbweb outside the pb directory, so I'll give that a shot again too.

            I'll post any changes back in this thread. Hopefully I'll have my first lag free game in months this weekend. :)
            Beatnik

            Comment


            • #7
              Re: Anyone still having choppy lag issues??

              Beatnik, my friend had the EXACT same problem. There was a connection interrupted message that popped up and then the game would freze. While frozen, everything continued on the same path, so tanks would keep on rotating and planes spinning out of control. Once it resumed, everything would be back to normal.

              The problem for him was the wireless card. It didn't have a fast enough signal speed or something, so he upgraded and problem solved. I don't know if you are using a wireless card or not, but mabey your ethernet card is out of date or old? Just some past experiences that might help.

              Comment


              • #8
                Re: Anyone still having choppy lag issues??

                Yeah I'm not using wireless but I am going through a router and like I said I just reformatted and reinstalled windows, so it may also be some kind of nforce2 driver issue. I may need to just forward that port. Right now I'm trying everything I can try... :)
                Beatnik

                Comment


                • #9
                  Re: Anyone still having choppy lag issues??

                  beatnik for the past couple of weeks i've had the same issues, and before my ping was always <20. But now its in the 40s and i get freeze-ups which spike it up to 400ms now. I wonder if its punk buster or what.

                  Comment


                  • #10
                    Re: Anyone still having choppy lag issues??

                    Sounds like the same problem... :(
                    Beatnik

                    Comment


                    • #11
                      Re: Anyone still having choppy lag issues??

                      I'm not sure if this is related, but nowadays I get long "connection problem" messages every 5 minutes or so. Everything goes back to normal after about 25 seconds, but during that time I normally die. Horribly.

                      [conduct][volun][drill][sg-c1][tpf-c1]
                      |TG-2nd|munchkin
                      Nec aspera terrent.

                      Comment


                      • #12
                        Re: Anyone still having choppy lag issues??

                        I've rarely had lag on the server, but lately I notice a little...but what really has me startled is when I go from prone to standing up I hit my space bar once (I suppose this is normal). Many times it doesn't register as quickly as I'd like so I instictively hit the space bar again...so instead of just standing up I am actually prone and "hop" up to a standing position. I apologize to everyone in my squad but it probably happens once or twice every time I play...

                        Don't have the "problem with your connection" messages very often, though...

                        Comment


                        • #13
                          Re: Anyone still having choppy lag issues??

                          Comcast finally made it to my apartment and he says everything on my end looks good. He did say that the signal is pretty high outside. Dont know what that means but at least for now it means I dont have to think about spending money on a new modem or router.

                          Comment


                          • #14
                            Re: Anyone still having choppy lag issues??

                            I can just add that I've had no connection lag or FPS issues lately. about a month ago I was having the connection interrupted issues your describing. I thought it might have been something to do with the fact that I'm going wireless. Turns out it wasn't that at all, my 54mbps wireless connection works great for gaming, it was a problem with the cable connection - which has been sorted out by brighthouse.

                            Doesn't help much, I know - but I'm pretty positive your problems aren't related to BF2 server #1 issues.

                            Comment


                            • #15
                              Re: Anyone still having choppy lag issues??

                              Originally posted by Coridon
                              I've rarely had lag on the server, but lately I notice a little...but what really has me startled is when I go from prone to standing up I hit my space bar once (I suppose this is normal). Many times it doesn't register as quickly as I'd like so I instictively hit the space bar again...so instead of just standing up I am actually prone and "hop" up to a standing position. I apologize to everyone in my squad but it probably happens once or twice every time I play...
                              You can avoid this by just hitting the prone button or the crouch button. Both will make you stand from prone.
                              Peace through fear... since 1947!

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X