No announcement yet.

Negative ping times???

  • Filter
  • Time
  • Show
Clear All
new posts

  • Negative ping times???

    After my rig has been worked out (playing BF2 or running a benchmark such as 3DMark05) for an extended period, I tend to have network connection problems. Please look at the following ping output and explain how my ping packets are able to travel through a wormhole and ack back before they left !

    C:\Documents and Settings\clittle>ping -n 5000

    Pinging with 32 bytes of data:

    Reply from bytes=32 time=45ms TTL=115
    Reply from bytes=32 time=59ms TTL=115
    Reply from bytes=32 time=196ms TTL=115
    Reply from bytes=32 time=-88ms TTL=115
    Reply from bytes=32 time=45ms TTL=115
    Reply from bytes=32 time=177ms TTL=115
    Reply from bytes=32 time=46ms TTL=115
    Reply from bytes=32 time=-57ms TTL=115
    Reply from bytes=32 time=51ms TTL=115
    Reply from bytes=32 time=59ms TTL=115
    Reply from bytes=32 time=46ms TTL=115
    Reply from bytes=32 time=44ms TTL=115
    Reply from bytes=32 time=36ms TTL=115
    Reply from bytes=32 time=-73ms TTL=115
    Reply from bytes=32 time=40ms TTL=115
    Reply from bytes=32 time=169ms TTL=115
    Reply from bytes=32 time=171ms TTL=115
    Reply from bytes=32 time=36ms TTL=115
    Reply from bytes=32 time=-84ms TTL=115
    Reply from bytes=32 time=167ms TTL=115
    Reply from bytes=32 time=37ms TTL=115
    Reply from bytes=32 time=-69ms TTL=115
    Reply from bytes=32 time=38ms TTL=115

    Ping statistics for
    Packets: Sent = 23, Received = 23, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 36ms, Maximum = -57ms, Average = 47ms

    Unfortunately, the negative ping times don't give me 'less than zero lag/latency', but they lead to disconnects (usually middle of a map when I've got the drop on someone :row__533: ).

    My next experiment is to try a different wireless NIC (I'm using a Netgear WG311T) to see if the NIC is getting too hot or has some instability. The ambient temperature in the case is around 32-35C (CPU is <=40C via water-cooling, and GPU is also water-cooled).

    The only other thing I can think of is that some MB component is cooking somehow. It is a ASRock 939Dual-SATA2. A reboot seems to be the only thing that resolves the problem (for a while).

    Any thoughts or ideas are appreciated.


    96th Assault Group

  • #2
    Re: Negative ping times???

    My guess is that the actual pinghas gone over some limit. Notice it says -57 is the maximum, when obveously there are other numbers larger.
    - The problem with taking the easy way out is that the enemy has already mined it.


    • #3
      Re: Negative ping times???

      Matrix lag!

      That is simply a glitch in the construct.

      I've had negative packloss before, but never negative ping. I can't imagine negative ping being anything other than corruption in the ping program or the ip stack. Or, as you say, something screwed on the mobo.
      Peace through fear... since 1947!


      • #4
        Re: Negative ping times???

        so are you saying you have anti-lag? Do you see people do things before they happen? =P

        99. A smiley face is not used to mark a minefield.
        100. Claymore mines are not filled with yummy candy, and it is wrong to tell new soldiers that they are.
        101. I am not allowed to mount a bayonet on a crew-served weapon.


        • #5
          Re: Negative ping times???

          I'd say you're probably got something wrong with your NIC
          |TG| Lorian
          Member since 18th February 2006


          • #6
            Re: Negative ping times???

            I am guessing all or most of those experiencing negative ping times are using the new dual core AMD cpu line. There appears to be a bug in the CPU, which AMD will not directly admit to or identify publicly. Being a big fan of AMD for years I find this very unfortunate since this has been affecting the AMD based servers I manage at work and the home machines of myself and many other people I know.

            After narrowing it down to the processor itself I started to put pressure on AMD for answers and was finally told to update the processor driver for all systems experiencing the problem. I did this at home last weekend and at work to almost a dozen servers and it has fixed the problem on ALL workstations and servers.

            From my discussions with AMD I have pieced together the following likely issue with the dual core processors. It seems there is a timing issue between the two cores that slowly causes the timing to drift further and further apart between the two cores. This is why rebooting the machine temporarily fixes the syptoms; atleast for a couple of hours. The longer the system is up the worse the problem appears to get until simple tasks such as web browsing and copying files becomes untolerable.

            Below is a link to AMD to get the latest processor driver which appears to correct the issue with the dual core processor.

            www . amd . com/us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html
            (sorry for the broken URL, the borad will not let me post a URL with less than 15 posts here under my belt)

            For those that may feel this problem still resides on the network side I can only say in the past two months I have tried 5 different brand NICs (netgear, HP, linksys, d-link, and an older Compaq server NIC), 4 different switchs (Cisco 6513, Cisco 2950, Netgear, and D-Link), and tried a straight crossover cable between two computers and non had any affect on the problem. I have also experienced the problem on 3 different system boards (Compaq DL385, MSI K8N Neo4, and an Asus board. I have flashed the BIOS repeatedly on all these boards and the Neo4 ensured I was running the latest nForce4 drives. None of this troubleshooting has any affect on the problem.

            In the past two or so months I have read about a lot of people having this problem but have not seen a fix for this posted anywhere so I am hoping this email can help at least one person save the months of meaningless troubleshooting I have to go through.

            If you find this to be help full at solving your problem please take a minute to spread the word.

            Network Administrator


            • #7
              Re: Negative ping times???

              Wow. I know this post was made quite a while ago, but I have had this issue at work.

              I'm glad google 'grabbed' it for me. The last place I would have looked is the *processor* for this issue. The way you explained it, though, makes perfect sense. I even analyzed my ICMP packets with Ethereal to find the reply's "timestamp" earlier than the request. Thanks for the post! This saved me a ton of time.


              • #8
                Re: Negative ping times???

                This is true that it is not a network issue. Here is the proof.

                ping -t

                Ping your local interface. If you still get a negative number. This means it is either a problem with the tcp/ip stack or as stated before the processor


                • #9
                  Re: Negative ping times???

                  You guys missed the obvious "he's playing from the future" joke. Sheesh.




                  TeamSpeak 3 Server




                  Twitter Feed