No announcement yet.

BF2VoiceSetup.exe Error

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • BF2VoiceSetup.exe Error

    Good evening all. Went to play BF2 last night for the first time since re-installing fresh from the OS on up (which I did last Saturday). It's never been a problem and the ONLY 2 things that have changed since the last time I did this are:

    1. One of my 512MB RAM sticks went bad last weekend so I'm running with 512MB right now.

    2. My primary HD has been upgraded from a 40GB drive to a 250GB drive.

    Absolutely nothing else has changed. VOIP worked BEFORE re-installing from scratch.

    BF2 installs fine, all of the patches, Tactical Mod stuff, POE, etc. install fine. When the VOIP Setup comes up during install I never got signal (which has happened in the past but in-game it has been fine) so I set the settings to what I remembered them to be last time and clicked Save. No errors at that point.

    Tried to play TacMod last night and I had sound and could hear others VOIP but noticed when I pushed to talk nothing showed as transmitting. So, I quit out of BF2 and went and ran BF2VoiceSetup and clicked Save again and got the error below.

    On the off chance something happened during any of the patching and POE install I re-installed everything, deleted my EA\BF2 folder and re-installed from scratch. After installing, prior to installing ANYTHING else (patch, POE or TacticalMod stuff) I re-ran VOIP and got the same error. :(

    Still using the headset I've had for 6 months or so, a Plantronics DSP-500 (USB). I know it's specific to BF2 because I can record a test voice clip in Windows Sound Recorder no problem.

    Any ideas? I'll try to get on and play some tonight and make sure everything else works as it should but I'll be sans VOIP until I get this figured out.

    I did a search on the .exe and didn't find much helpful information so I'm hoping a TG brother has some ideas. :)

    Attached Files

  • #2
    Re: BF2VoiceSetup.exe Error

    OK, well, weird solution to this. I got to reading some posts on PlanetBattlefield 2 and one suggestion I saw a couple of times was to run VOIP Setup a second time, move the sliders a bit, get the error and then try it in-game.

    As weird as it sounds that seems to have done it. I need to tweak a bit but I just jumped into POE long enough to get a comm check and it was good.

    I won't question it, I'll just be happy my problem is solved. :)




    TeamSpeak 3 Server




    Twitter Feed