Announcement

Collapse
No announcement yet.

older version?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • older version?

    I spent 3 hours today trouble shooting my POE2 download and got it to work finally! however, i try to join your server by IP and it says "your version is older than the one on the server" now i have 1.0. the kind it lets me download from the POE2 official website, now it says also that the new patch 1.1.5 is coming out tommorow...so why cant i get on tonight? i checked for a patch on the site and did not find one...can any one help me?

  • #2
    Re: older version?

    There has only been one version of the POE2 client as of today. However, there have been multiple versions of BF2. Is your BF2 version up to date?
    -33rd- BaneII
    Smokers & Jokers

    Comment


    • #3
      Re: older version?

      yep, was about to edit the post stating im a moron. its my BF2 thats out of date sorry.

      Comment


      • #4
        Re: older version?

        Dave i honestly dont think you are a moron, we cant blame you for hanging around root and dan for all those months. It was bound to rub off onto a good player like yourself.
        that sounds like a good idea trooper.
        -Vulcan

        Comment


        • #5
          Re: older version?

          yet another tech problem! i recently upgraded my Bf2 version to 1.4, tried to connect to your TG poe2 server at 2:57 estern time. it disconnected me and said "this server doesnt allowed modded game types, revert to original BF2 and try again" now taht could be because of the server not having 1.5 of POE2 installed, but if that is not the case i want to get a head start on this so that i can play (finally) tonight.

          Comment

          Connect

          Collapse

          TeamSpeak 3 Server

          Collapse

          Advertisement

          Collapse

          Twitter Feed

          Collapse

          Working...
          X