Announcement

Collapse
No announcement yet.

1.5 patch refuses to let BF2 play

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.5 patch refuses to let BF2 play

    Howdy.
    I downloaded the new 1.5 patch (i had been up to 1.41 before) and it installed ok.
    When i run BF2, or any mods, i can get to the main screen. As soon as i click on anything (Singleplayer, Multiplayer, Community etc etc) it Crashes to desktop.
    Ive tried running in several different compatibility modes and allways as admin.
    Im on Vista 32bit.

    Any ideas?
    Nihility

  • #2
    Re: 1.5 patch refuses to let BF2 play

    use XP? LOL
    "Everyone makes fun of us rednecks with our big trucks and all our guns........until the zombie apocalypse"

    Comment


    • #3
      Re: 1.5 patch refuses to let BF2 play

      make sure you are not using the latest nvidia drivers, 190.62, as there seems to be a conflict between it and BF2. I had them installed and would always ctd with any BF2 mod or vanilla but once i reverted back to 186.18 everything worked fine. I run Vista 64 bit btw.

      Comment

      Connect

      Collapse

      TeamSpeak 3 Server

      Collapse

      Advertisement

      Collapse

      Twitter Feed

      Collapse

      Working...
      X