Announcement

Collapse
No announcement yet.

Cant patch BF2 after install

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cant patch BF2 after install

    Hey I reinstalled my OS and now I cant get BF2 to update after installation. I have verified that it installed, I even reinstalled. It tells me that I cannot run the update because the version I have is newer than the patch im trying to run (1.5). Any ideas?

    BTW this is on Windows 7

  • #2
    Re: Cant patch BF2 after install

    I ran into the same problem. The problem shouldn't be your OS, the problem is the error message on the patcher is misleading. They didn't make a unified installer for this patch, and the installer only checks one version number (1.41) and quits if it doesn't detect it. Stupid, IMO.

    What you will need to do is download the 1.41 patch (should include everything in the previous patches), patch the game with that, and THEN run the 1.50 patch. That worked for me.

    <04:11:24> *** You are now talking in channel: "TFP - Task Force Proteus"
    <04:16:25> "|TG-XV| Tralic": this channel is so gay
    DICE needs to make a comical boxing glove attached to a spring punch the player in the face 40% of the time they get into a helicopter or jet.

    Comment


    • #3
      Re: Cant patch BF2 after install

      I ran into the same error while patched to 1.41 and attempting to patch to 1.5. I repatched with 1.41 and then 1.5 ran without a hitch. I would bet the above advice from Bisclaveret gets you going. GL!
      MANUS HAEC INIMICA TYRANNIS

      Comment


      • #4
        Re: Cant patch BF2 after install

        Ill try that, thanks. Thats kinda stupid of EA to do it like that... but w/e. Ill have to dl it again cause I already deleted it lol. Thanks guys.

        Comment


        • #5
          Re: Cant patch BF2 after install

          I had the hardest time downloading 1.41 after several times of installing I would get a message Failed install. I kept installing it and it finally worked and then installed 1.5 and that worked as well.

          Comment

          Connect

          Collapse

          TeamSpeak 3 Server

          Collapse

          Advertisement

          Collapse

          Twitter Feed

          Collapse

          Working...
          X