Announcement

Collapse
No announcement yet.

no sound in game when using teamspeak

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • no sound in game when using teamspeak

    Hello all,

    Getting a strange intermittent problem whereby I get no in game sound if I have teamspeak running, this doesn't happen all the time but it is pretty frequent, anyone experienced similar?

    xfi fatality titanium
    windows 7 x64
    gtx 480

    i'm using standard stereo headset with headphone jack and mic, when it works it works flawless, most often however I get no sound in battlefield but sound everywhere else.

    cheers for any help guys.



    AKA TG Xink | http://www.andy-hook.co.uk

  • #2
    Re: no sound in game when using teamspeak

    Every time I plug in my headset to the front ports I have to go into windows sound properties and configure the playback device for stereo, for some reason windows does not change it from 7.1 surround to stereo, also make sure the Mic is set to "default device" and not "default communication device" by right clicking on it.

    I hope this helps as it did help me out with a similar problem with the same sound card.

    Comment


    • #3
      Re: no sound in game when using teamspeak

      This almost certainly isn't the issue, but it's worth checking - in your TS, click 'settings', then 'setup wizard', and click through until you see 'enable volume control'. Un-tick the box and disable it. Volume control quietens other applications when someone in TS is talking, but in my experience it vastly overcompensates and basically silences everything. If someone in your channel is talking a lot, or has a voice-activated mic with a low threshold, volume control could be on all the time.
      |TG-Irr| westyfield

      Sig pic by Sonic, avatar by Chalcas. Thanks!
      Irregular since 2007.

      Comment


      • #4
        Re: no sound in game when using teamspeak

        thanks for the response guys, I did some testing and it only happens if TS is running before I launch the game, a quick workaround i'm using is to just launch TS after I have connected to the server.



        AKA TG Xink | http://www.andy-hook.co.uk

        Comment


        • #5
          Re: no sound in game when using teamspeak

          I had this issue and I solved it. TeamSpeak 3->Settings->Plugins (Ctrl+Shift+P) and uncheck the "Volume Control" plugin. I haven't had a problem since I did this.
          Iím not racists, I have republican friends. Radio show host.
          - "The essence of tyranny is the denial of complexity". -Jacob Burkhardt
          - "A foolish consistency is the hobgoblin of little minds" - Emerson
          - "People should not be afraid of it's government, government should be afraid of it's People." - Line from V for Vendetta
          - If software were as unreliable as economic theory, there wouldn't be a plane made of anything other than paper that could get off the ground. Jim Fawcette
          - "Let me now state what seems to me the decisive objection to any conservatism which deserves to be called such. It is that by its very nature it cannot offer an alternative to the direction in which we are moving." -Friedrich Hayek
          - "Don't waist your time on me your already the voice inside my head." Blink 182 to my wife

          Comment


          • #6
            Re: no sound in game when using teamspeak

            I just had a no in game sound problem for 2 days. Serched the web and found a lot of people were having this problem. I
            found a fix that was so easy I couldn't believe it, but it worked. here it is

            if you are on windows 7 follow this: open battlefield 3 - alt Enter to your desktop - click on the volume button on the? right bottom of your screen - click on it and click on "mixer" (looks like a link) - and search bf3 in it and set the volume higher :).

            Hope this helps someone
            sigpicBF3

            Comment


            • #7
              Re: no sound in game when using teamspeak

              Originally posted by red-dwarf-001 View Post
              I just had a no in game sound problem for 2 days. Serched the web and found a lot of people were having this problem. I
              found a fix that was so easy I couldn't believe it, but it worked. here it is

              if you are on windows 7 follow this: open battlefield 3 - alt Enter to your desktop - click on the volume button on the? right bottom of your screen - click on it and click on "mixer" (looks like a link) - and search bf3 in it and set the volume higher :).

              Hope this helps someone
              thanks will try it tonight

              Comment

              Connect

              Collapse

              TeamSpeak 3 Server

              Collapse

              Advertisement

              Collapse

              Twitter Feed

              Collapse

              Working...
              X