Announcement

Collapse
No announcement yet.

Audio echo

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Audio echo

    Good Day to all!

    Im having a bad audio echo in all modes of game anyone have any ideas? its like every sound plays twice.

    thanks

  • #2
    Re: Audio echo

    Please list out your hardware spec's and how you have in configured.

    Comment


    • #3
      Re: Audio echo

      Check several settings. I know BF3 is Origin-based, but I had a similar issue when using Steam voip. It turned out that some mic setting in the Steam games caused feedback. Check the game, Origin, and audio driver software.


      Comment


      • #4
        Re: Audio echo

        make sure your options for audio loopback are disabled in battlelog, TS and windows audio options. unplug any microphones.

        have you tried playing with headphones on?
        -Glycerin256 <-- add me in Battlelog, Steam, Origin. Sig rig MIGHT BE FOR SALE: i5 2500k @ 4.5Ghz; AsRock Z68 Extreme4; 16GB DDR3 1866; Asus GTX 970; 500GB 840 EVO SSD; Xonar DX 7.1; Win7x64, 25.5" T260HD, etc

        Comment

        Connect

        Collapse

        TeamSpeak 3 Server

        Collapse

        Advertisement

        Collapse

        Twitter Feed

        Collapse

        Working...
        X