Announcement

Collapse
No announcement yet.

In-Game VOIP Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • In-Game VOIP Issues

    For some reason, I can't seem to get sound from squadmates over in-game VOIP. I think they can hear me because their speaker icons light up when I try to talk to them but I don't get any sound back. I made sure that VOIP was on in the game settings and even turned the VOIP volume to 100% but I still get nothing. I've also tried setting my sound to stereo to make sure that the VOIP wasn't getting lost over another audio channel.

    Sound over TS works fine.

    I'm running a Asus Xonar DG 5.1.

    Has anyone else run into this issue?
    sigpic

  • #2
    Re: In-Game VOIP Issues

    I mostly have problems with peoples voice being too low, I created a thread about it in BL, feel free to add your problems to it.

    http://battlelog.battlefield.com/bf4...4763446587167/

    Voip is buggy, I sometimes create my own squad and lock it just to test out some things and sometimes hear people talking even though I am the only one in the squad.

    Comment


    • #3
      Re: In-Game VOIP Issues

      Thanks, Mojay. There is the possibility that the sound is just too low for me to pick up. I'll have to test it out and see.

      Anyone else having issues?
      sigpic

      Comment


      • #4
        Re: In-Game VOIP Issues

        Originally posted by weaponx77 View Post
        For some reason, I can't seem to get sound from squadmates over in-game VOIP. I think they can hear me because their speaker icons light up when I try to talk to them but I don't get any sound back. I made sure that VOIP was on in the game settings and even turned the VOIP volume to 100% but I still get nothing. I've also tried setting my sound to stereo to make sure that the VOIP wasn't getting lost over another audio channel.

        Sound over TS works fine.

        I'm running a Asus Xonar DG 5.1.

        Has anyone else run into this issue?
        This happens to me IF I unplug my speakers AFTER starting the game. I unplug the speakers to channel the sound to me headphones, but due to some obscure settings on my rig, I need to do this before starting BF4.

        Can you hear me know . . .
        sigpic

        Comment


        • #5
          Re: In-Game VOIP Issues

          Originally posted by weaponx77 View Post
          Thanks, Mojay. There is the possibility that the sound is just too low for me to pick up. I'll have to test it out and see.

          Anyone else having issues?
          I had to turn up my center speakers on my surround sound Turtle Beach headset to hear squadmates voices properly.

          Comment


          • #6
            Re: In-Game VOIP Issues

            I am having an issue where squad mates cannot hear me when I am dead.

            Comment


            • #7
              Re: In-Game VOIP Issues

              I had to right click the Speaker icon in the Windows status bar, the choose 'playback devices', then 'set as default communication device'. Otherwise VOIP went to my desktop speakers (which were off) instead of my headset.

              Comment


              • #8
                Re: In-Game VOIP Issues

                Thanks for the help, iWhiskey! I would never have figured this out on my own.
                Last edited by weaponx77; 10-09-2013, 06:50 AM.
                sigpic

                Comment


                • #9
                  Re: In-Game VOIP Issues

                  Originally posted by weaponx77 View Post
                  Thanks for the help, Whiskey! I would never have figured this out on my own.
                  Not a problem man. :)

                  For others, I have updated the B4 Fixes and Solution Thread with the following:

                  Issue: I can't hear my squadmates/VoIP isn't working

                  Solution: First, go into the in-game settings and turn the VoIP volume to the maximum the slider allows, and make sure the checkbox for lowing the in-game sound when VoIP is active is checked.

                  Solution: Change the in-game sound mode to hi-fi or headphones. In-game VoIP uses the Central audio channel (for programmers or WINE users, this is the FXMXIS_CENTRALSUB2 channel), and this can be masked or lowered by certain sets of speakers and headphones.

                  Solution: Make sure teamspeak is not set to lower the volume of other applications. This is in the Teamspeak settings as "attenuate when I speak", or the volume plugin.

                  Solution: Make sure your primary output device is set as your communication device in windows. To do this, right click on the volume control panel at the bottom right of the desktop, go to Playback Devices, and disable any device that you are not currently using for playback. Set your primary playback device as the communication device in the right click menu.

                  Comment


                  • #10
                    Re: In-Game VOIP Issues

                    Originally posted by Henry_Killinger View Post
                    I am having an issue where squad mates cannot hear me when I am dead.
                    Ditto
                    |TG|Melee
                    Clear Eyes, Full Hearts, Can't Lose!

                    Comment


                    • #11
                      Re: In-Game VOIP Issues

                      Originally posted by Henry_Killinger View Post
                      I am having an issue where squad mates cannot hear me when I am dead.
                      I think that is the way it should be. The dead are not suppose to speak. Would be creepy. Seriously, I think some of the servers are set to disallow speaking while dead. I have communicated before while "offline" so it does happen in some cases.

                      Comment


                      • #12
                        Re: In-Game VOIP Issues

                        A "dead men don't talk' setting is quite appealing in some aspects. Could encourage maintenance of better situational awareness, knowing where all your squad are, having line of sight on them where possible etc. Hmm, could encourage better comms and more 'check ins', "What's up with Wicks today, he's not saying much", as I lay on the ground with an RPG embedded in my face lol. Interesting.


                        Comment


                        • #13
                          Re: In-Game VOIP Issues

                          For those of us with a maxed out intelligence bar....I was having the same problem with no one being able to hear me in BF4. After trying all the fixes I could think of, many listed above, I found a tiny microphone mute switch on my head set that I had been unaware of. Apparently my seven year old son was aware of it and switched the mic off.

                          When he was five, he also found the mute switch on my new iphone before I did, and caused me a good hour or so of hair pulling until I found out why the damn thing wouldn't ring. Spook = moron. Don't be a Spook.
                          SPOOK...
                          "Good tactics can save even the worst strategy. Bad tactics will destroy even the best strategy." - George S. Patton

                          Comment


                          • #14
                            Re: In-Game VOIP Issues

                            Originally posted by OldGunney View Post
                            I think that is the way it should be. The dead are not suppose to speak.
                            I agree, the dead shouldn't be able to pass on intel about what just happened to cause their death. But I got the impression that the dead were able to talk to each other. I could be wrong - with people talking in TS at the same time it can get a bit confusing.
                            |TG|Melee
                            Clear Eyes, Full Hearts, Can't Lose!

                            Comment


                            • #15
                              Re: In-Game VOIP Issues

                              when spawned in I use a mouse button for voip
                              when dead and looking at the deploy menu, that same mouse voip button stops working, so I use the default left alt button

                              Comment

                              Connect

                              Collapse

                              TeamSpeak 3 Server

                              Collapse

                              Advertisement

                              Collapse

                              Twitter Feed

                              Collapse

                              Working...
                              X