Announcement

Collapse
No announcement yet.

Bad Company 2, The White Screen of Death & the Great Cover-up

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bad Company 2, The White Screen of Death & the Great Cover-up

    This is an interesting topic for me, not just because my BC2 play on the PC is currently on hold because of this very issue, but because of how EA/DICE/Nvidia/ATI are handling it....which is to say, seemingly not at all.

    Just about everyone that's played the game knows about the white screen of death by now. I've read plenty of reports all over the web about this, and it basically boils down to between 2-30 minutes of normal game play before the screen goes white. Most people report still hearing regular sound, as well as being able to control their avatar (i.,e. you click your LMB and hear gunfire).

    Nobody has been able to really pinpoint the reason for the WSOD, except that it's very prevalent with Nvidia SLI and/or Windows 7 64x users.

    Fixes are just as, if not more nebulous. I've seen everything from changing the .exe file to BF2, to tweaking the Nvidia control console so the app determines the settings, to editing .ini files. I admit I haven't tried everything yet, in some cases because my particular setup won't let me.

    I was sort of hoping that this recent update was going to address the problem, but alas, it hasn't. This concerns me quite a bit, since DICE/EA has been silent regarding this issue, even as their forums accumulate more and more glitch reports.

    I'm also a little surprised to not see much talk about this here on the TG forums, so I decided to start this thread.

    Thus, the objectives:

    1) If you are having this problem, make yourself known. Post your system specs. List what fixes you've tried and how well they've worked, if at all.
    2) Discuss any news you've heard from GPU companies, EA or DICE regarding this issue.
    3) Discuss any possible third party groups that are working on or have released a possible fix.

    I know I'm not the only one incredibly frustrated with this problem. BFBC2 is the reason I started actively participating in TG again, but now the risk of once more going gently into that dark night is very real.


    |TG|Serafiel - Pfälzer Wolf
    "For he to-day that sheds his blood with me shall be my brother"
    - King Henry V, Shakespeare's "Henry V"

  • #2
    Re: Bad Company 2, The White Screen of Death & the Great Cover-up

    And since it's my thread, I'll start off with my system specs...

    GPU: Nvidia Geforce GTS 250 (3817MB)
    CPU: Intel Core i7 920 @ 2.67 GHz
    RAM: 6144MB DDR3
    DirectX 11
    Windows 7 Ultimate 64x

    So far I've tried....
    1) Changing the BFBC2Game.exe to BF2.exe. Since I got the game through Steam, it won't load properly when I do this. However, I've heard some people have had success with it if they bought a retail copy, or did it through EA. The reason it works, so I'm told, is because renaming the .exe to BF2 has your Nvidia recognize it as the original BF2 and apply a specified profile to it. Dunno if that's true, just what I've heard.
    2) Tried forcing DirectX 9 in the settings.ini files. This worked for a while, but then I started getting lag and graphic tearing issues after a while.

    Currently, I'm trying EVGA Precision 1.9.1 to keep my GPU fan speed steady at 80%. There's quite a bit of literature on how this may be a heat issue. Will report back if this extends my play time at all. If it doesn't work, at least I'll have an idea of how taxing BC2 is on my system....


    |TG|Serafiel - Pfälzer Wolf
    "For he to-day that sheds his blood with me shall be my brother"
    - King Henry V, Shakespeare's "Henry V"

    Comment


    • #3
      Re: Bad Company 2, The White Screen of Death & the Great Cover-up

      Same Problem here. Havnt found a fix yet here is my system specs
      Mac Pro
      Intel W3520 8Core 2.8GHz
      Windows 7 Ultimate x64
      nVidia GT120 (3305Mb)
      8GB Ram
      DX11

      Ive tried messin with the .ini files and also with a few different nVidia performance settings but nothing works so far. Messing with the fan speed through nVidia control panel now and will post back if that helps at all.

      Comment


      • #4
        Re: Bad Company 2, The White Screen of Death & the Great Cover-up

        So increasing the fan speed to 80% of max extends my playtime marginally...but the problem persists. At this point, I'm sort of our of ideas, aside from trying to pinpoint this problem.

        So far, my bet is on the fact that my GTS 250 is SLI, as my brother has been running the game fine, and the only real difference between his system and mine is that his nVidia GPU is a single, not an SLI.


        |TG|Serafiel - Pfälzer Wolf
        "For he to-day that sheds his blood with me shall be my brother"
        - King Henry V, Shakespeare's "Henry V"

        Comment


        • #5
          Re: Bad Company 2, The White Screen of Death & the Great Cover-up

          I have not had this problem, and I have a similar system to yours except I have an ATI card using DX10.

          Comment


          • #6
            Re: Bad Company 2, The White Screen of Death & the Great Cover-up

            I get the "epileptic black screen of death".

            My screen goes black for 1-2 sec before going back to normal for about .5 sec, this repeats and the screen eventually goes black for 5-35 sec, then back to normal for the rest of my session on the server.

            I can see a few 3D map objects like spotted enemies and objectives, and my reticule. I have an Nvidia GTX260M, that's mobile because I have a laptop, which may well be the problem.

            As for fixing it, cursing at your computer for the duration seems to work for me :P

            Comment


            • #7
              Re: Bad Company 2, The White Screen of Death & the Great Cover-up

              Originally posted by Tarmus View Post
              I get the "epileptic black screen of death".

              My screen goes black for 1-2 sec before going back to normal for about .5 sec, this repeats and the screen eventually goes black for 5-35 sec, then back to normal for the rest of my session on the server.
              Tarmus, I think you and I have the same problem. Occasionally I will get the same flickering black screen issue that you described where the screen will flash between game graphics (what I should be seeing) and a flickering blacked out screen. If I'm lucky, the flickering will be very brief and go away quickly. If I'm less lucky, it will continue flashing intermittently before eventually going away. And If I'm really unlucky, it will begin to flash even more heavily and eventually become solid black. If this happens, I'm really only left with 2 options: Either wait it out for who knows how long or quit the game and restart BC2. I should also point out that while the visuals are going haywire everything else appears to work correctly. I can hear all the audio and I can still move my avatar and shoot.

              I'm using nvidia SLI for graphics. I've narrowed down the possible causes to:

              1. Weird SLI/driver issues
              2. Buggy coding
              3. Graphics card overheating

              Ordinarily I would guess number 3 is the culprit, but this has happened earlier, in the winter months, where I never have to worry about heat issues. For now, I'm just chalking it up to a combination of 1 and 2.
              "Looking for brahs to come fight crime with me" - Unload



              Comment

              Connect

              Collapse

              TeamSpeak 3 Server

              Collapse

              Advertisement

              Collapse

              Twitter Feed

              Collapse

              Working...
              X